OSPF – Discontiguous Area

Multi-area OSPF

OSPF routing has been configured as shown in the network diagram. A link at 172.16.10.4/30 is broken. There’s no backup link for area 0 between 2651-1 and 2651-2, hence area 2 becomes discontiguous.

Before link breakage

1841-1#sh ip route ospf
2.0.0.0/32 is subnetted, 1 subnets
O       2.2.2.2 [110/2] via 172.16.10.2, 00:39:23, FastEthernet0/0
3.0.0.0/32 is subnetted, 1 subnets
O       3.3.3.3 [110/2] via 172.16.10.6, 00:40:47, FastEthernet0/1
4.0.0.0/32 is subnetted, 1 subnets
O IA    4.4.4.4 [110/3] via 172.16.10.2, 00:12:33, FastEthernet0/0
192.168.1.0/30 is subnetted, 2 subnets
O IA    192.168.1.0 [110/2] via 172.16.10.2, 00:13:22, FastEthernet0/0
O IA    192.168.1.4 [110/2] via 172.16.10.6, 00:13:43, FastEthernet0/1

2651-2#sh ip route ospf
1.0.0.0/32 is subnetted, 1 subnets
O       1.1.1.1 [110/2] via 172.16.10.5, 00:14:22, FastEthernet0/1
2.0.0.0/32 is subnetted, 1 subnets
O       2.2.2.2 [110/3] via 172.16.10.5, 00:14:22, FastEthernet0/1
4.0.0.0/32 is subnetted, 1 subnets
O IA    4.4.4.4 [110/4] via 172.16.10.5, 00:13:27, FastEthernet0/1
172.16.0.0/30 is subnetted, 2 subnets
O       172.16.10.0 [110/2] via 172.16.10.5, 00:14:22, FastEthernet0/1
192.168.1.0/30 is subnetted, 2 subnets
O IA    192.168.1.0 [110/3] via 172.16.10.5, 00:13:27, FastEthernet0/1

After link breakage

2651-2#sh ip route
3.0.0.0/32 is subnetted, 1 subnets
C       3.3.3.3 is directly connected, Loopback3
192.168.1.0/30 is subnetted, 1 subnets
C       192.168.1.4 is directly connected, FastEthernet0/0

1841-1#sh ip route ospf
2.0.0.0/32 is subnetted, 1 subnets
O       2.2.2.2 [110/2] via 172.16.10.2, 00:02:14, FastEthernet0/0
4.0.0.0/32 is subnetted, 1 subnets
O IA    4.4.4.4 [110/3] via 172.16.10.2, 00:02:14, FastEthernet0/0
192.168.1.0/30 is subnetted, 1 subnets
O IA    192.168.1.0 [110/2] via 172.16.10.2, 00:02:14, FastEthernet0/0

Virtual link

Virtual link established between 2651-1 and 2651-3, router ospf 1 process peer to each other's router-id within area 1.

2651-3(config-router)#area 1 virtual-link 22.22.22.22

2651-1(config-router)#area 1 virtual-link 44.44.44.44

After virtual link was configured

2651-2#sh ip route ospf
1.0.0.0/32 is subnetted, 1 subnets
O IA    1.1.1.1 [110/4] via 192.168.1.6, 00:04:05, FastEthernet0/0
2.0.0.0/32 is subnetted, 1 subnets
O IA    2.2.2.2 [110/3] via 192.168.1.6, 00:04:05, FastEthernet0/0
4.0.0.0/32 is subnetted, 1 subnets
O IA    4.4.4.4 [110/2] via 192.168.1.6, 00:04:38, FastEthernet0/0
172.16.0.0/30 is subnetted, 1 subnets
O IA    172.16.10.0 [110/3] via 192.168.1.6, 00:04:05, FastEthernet0/0
192.168.1.0/30 is subnetted, 2 subnets
O IA    192.168.1.0 [110/2] via 192.168.1.6, 00:04:38, FastEthernet0/0

1841-1#sh ip route ospf
2.0.0.0/32 is subnetted, 1 subnets
O       2.2.2.2 [110/2] via 172.16.10.2, 00:24:13, FastEthernet0/0
4.0.0.0/32 is subnetted, 1 subnets
O IA    4.4.4.4 [110/3] via 172.16.10.2, 00:08:30, FastEthernet0/0
192.168.1.0/30 is subnetted, 2 subnets
O IA    192.168.1.0 [110/2] via 172.16.10.2, 00:24:13, FastEthernet0/0
O IA    192.168.1.4 [110/3] via 172.16.10.2, 00:08:30, FastEthernet0/0

GRE tunnel

GRE tunnel is created on top of the actual ip subnet and the actual physical interface. This tunnel acts like a virtual link, and is advertised as area 0, to 2651-3 it sees itself to have 3 interfaces: tunnel 0 interface in Area 0, fa0/1 in Area 1, fa0/0 in Area 2, hence this patch up the discontiguous Area 2.

2651-1#sh run int tu0
Building configuration…

Current configuration : 143 bytes
!
interface Tunnel0
ip address 10.0.0.1 255.255.255.248
ip ospf 1 area 0
tunnel source FastEthernet0/1
tunnel destination 192.168.1.2
end

2651-3#sh run int tu0
Building configuration…

Current configuration : 143 bytes
!
interface Tunnel0
ip address 10.0.0.4 255.255.255.248
ip ospf 1 area 0
tunnel source FastEthernet0/1
tunnel destination 192.168.1.1
end

Routing table of 2651-2 after GRE tunnel was configured.

2651-2#sh ip route ospf
1.0.0.0/32 is subnetted, 1 subnets
O IA    1.1.1.1 [110/11114] via 192.168.1.6, 00:22:40, FastEthernet0/0
2.0.0.0/32 is subnetted, 1 subnets
O IA    2.2.2.2 [110/11113] via 192.168.1.6, 00:22:40, FastEthernet0/0
4.0.0.0/32 is subnetted, 1 subnets
O IA    4.4.4.4 [110/2] via 192.168.1.6, 00:23:07, FastEthernet0/0
172.16.0.0/30 is subnetted, 1 subnets
O IA    172.16.10.0 [110/11113] via 192.168.1.6, 00:22:40, FastEthernet0/0
10.0.0.0/29 is subnetted, 1 subnets
O IA    10.0.0.0 [110/11112] via 192.168.1.6, 00:23:07, FastEthernet0/0
192.168.1.0/30 is subnetted, 2 subnets
O IA    192.168.1.0 [110/2] via 192.168.1.6, 00:23:07, FastEthernet0/0

1841-1 knows the route to Area 2 after GRE ws configured

1841-1#sh ip route ospf
2.0.0.0/32 is subnetted, 1 subnets
O       2.2.2.2 [110/2] via 172.16.10.2, 01:24:24, FastEthernet0/0
4.0.0.0/32 is subnetted, 1 subnets
O IA    4.4.4.4 [110/3] via 172.16.10.2, 01:24:24, FastEthernet0/0
10.0.0.0/29 is subnetted, 1 subnets
O       10.0.0.0 [110/11112] via 172.16.10.2, 00:27:09, FastEthernet0/0
192.168.1.0/30 is subnetted, 2 subnets
O IA    192.168.1.0 [110/2] via 172.16.10.2, 01:24:24, FastEthernet0/0
O IA    192.168.1.4 [110/11113] via 172.16.10.2, 00:24:09, FastEthernet0/0

1841-1#ping 192.168.1.5

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.5, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms

 

Alternatively use GRE tunnel to extend Area 2 until the ABR 2651-1

2651-1#sh run int tu0
Building configuration…

Current configuration : 143 bytes
!
interface Tunnel0
ip address 10.0.0.1 255.255.255.248
ip ospf 1 area 2
tunnel source FastEthernet0/1
tunnel destination 192.168.1.2
end

2651-3#sh run int tu0
Building configuration…

Current configuration : 143 bytes
!
interface Tunnel0
ip address 10.0.0.4 255.255.255.248
ip ospf 1 area 2
tunnel source FastEthernet0/1
tunnel destination 192.168.1.1
end

The result is the same, either you use GRE tunnel to extend Area 0 to ABR 2651-3 or extend Area 2 to ABR 2651-1

Advertisements
This entry was posted in OSPF, Route and tagged , , . Bookmark the permalink.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s