OSPF workaround: Using GRE tunnel as the back up ospf link

GRE tunnel is created on top of the actual ip subnet and the actual physical interface. This tunnel acts like a virtual link, and is advertised as area 0, to 2651-3 it sees itself to have 3 interfaces: tunnel 0 interface in Area 0, fa0/1 in Area 1, fa0/0 in Area 2, hence this patch up the discontiguous Area 2.

The link of subnet 172.16.10.4/30 is fixed, a backup physical link between 2651-1 and 2651-2 is proposed as backup link for area 0. As of current to prevent Area 2 from becoming discontiguous should the link of 172.16.10.4/30 is broken, GRE tunnel between 2651-1 and 2651-3 should be intact until a physical link is connected between 2651-1 and 2651-2.

Cost adjustment for GRE tunnel

2651-1#

interface Tunnel0
ip address 10.0.0.1 255.255.255.248
ip ospf cost 10
ip ospf 1 area 0
tunnel source FastEthernet0/1
tunnel destination 192.168.1.2
end

2651-3#

interface Tunnel0
ip address 10.0.0.4 255.255.255.248
ip ospf cost 10
ip ospf 1 area 0
tunnel source FastEthernet0/1
tunnel destination 192.168.1.1
end

The tunnel should not be the primary link if there’s no link breakage.

Ensure primary physical link is used

2651-2#traceroute 4.4.4.4

Type escape sequence to abort.
Tracing the route to 4.4.4.4

1 172.16.10.5 0 msec 4 msec 0 msec
2 172.16.10.2 4 msec 0 msec 4 msec
3 192.168.1.2 0 msec *  0 msec

1841-1#traceroute 4.4.4.4

Type escape sequence to abort.
Tracing the route to 4.4.4.4

1 172.16.10.2 4 msec 0 msec 4 msec
2 192.168.1.2 0 msec *  0 msec

 

Motivation to use GRE tunnel instead of virtual link

I can adjust ospf cost within a GRE tunnel like any other physical link, a virtual link however has no option to adjust the ospf cost hence path manipulation cannot be controlled using virtual link. A virtual link is simply established a link from discontiguous area to area 0 through transit area 1.

Advertisements
This entry was posted in OSPF, Route and tagged , . Bookmark the permalink.

One Response to OSPF workaround: Using GRE tunnel as the back up ospf link

  1. t3mp says:

    Disadvantages: If you have backbone MTU 1500, using GRE Tunnel we got fragmentation issue or Path MTU Black Holes.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google+ photo

You are commenting using your Google+ account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

w

Connecting to %s