Cisco Systems: Virtual Switching System

Virtual Switching System
If you have used Cisco catalyst 3750 stackwise technology you will grasp this VSS concept quickly. VSS is supported on the 6500 series switch platform that uses Sup720-10GE, the lab I did however is based on Cisco Catalyst 6509 Sup2T-10GE. The virtual switch link must be run on 10GE port which the supervisory engine has two of these 10GE ports.

The idea is to combine the two 6509 chassis into one logical switch, all the switch ports of the two chassis will be logically unified. There will be one active 6509 and one standby 6509, you cannot do any configuration or show task on the standby 6509. See below.

CSW-01-sdby>
Standby console disabled

CSW-01-sdby>

The hostname will also be unified and will base on the active switch’s host name.

Configure the first switch: VSS switch number and virtual switch link number
On the first 6509 switch, configure it to be switch 1.

configure terminal
switch virtual domain 10
switch 1
exit

Once you have assigned the switch number just exit, DO NOT ASSIGN SWITCH PRIORITY YET! If you assign switch priority after assigning the number you will encounter virtual switch link configuration problem that looks like this %Please configure local switch number first under the port-channel interface.
Create a port channel and assign this to be virtual switch link 1.

interface port-channel 1
no shutdown
no ip address
switch virtual link 1
exit

Assign the SUP2T-10GE ports to the port-channel 1.

interface range te5/4-5
no shutdown
no ip address
channel-group 1 mode on
end

The port-channel 1 will be down because the second switch has not done the port-channel configuration yet:

CSW-01#sh etherchannel summary
Flags:  D - down        P - bundled in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      N - not in use, no aggregation
        f - failed to allocate aggregator

        M - not in use, no aggregation due to minimum links not met
        m - not in use, port not aggregated due to minimum links not met
        u - unsuitable for bundling
        d - default port

        w - waiting to be aggregated
Number of channel-groups in use: 3
Number of aggregators:           3

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
1      Po1(RD)          -        Te5/4(D)       Te5/5(D)
2      Po2(RD)          -
10     Po10(SD)         -        Gi6/1(D)

Configure second switch: VSS switch number and virtual switch link number
Configure second switch and assign switch 2:

configure terminal
switch virtual domain 10
switch 2
exit

Create port channel 2 and assign switch virtual link 2.

interface port-channel 2
no shut
no ip address
switch virtual link 2
exit

Assign the physical 10GE ports of the SUP2T-10GE to the port-channel.

interface range te5/4-5
no shutdown
no ip address
channel-group 2 mode on
exit

Check the etherchannel it should be up:

CSW-02#sh etherchannel summary
Flags:  D - down        P - bundled in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      N - not in use, no aggregation
        f - failed to allocate aggregator

        M - not in use, no aggregation due to minimum links not met
        m - not in use, port not aggregated due to minimum links not met
        u - unsuitable for bundling
        d - default port

        w - waiting to be aggregated
Number of channel-groups in use: 2
Number of aggregators:           2

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
2      Po2(RU)          -        Te5/4(P)       Te5/5(P)
10     Po10(SD)         -        Gi6/1(D)

CSW-02#

You can assign the switch priority now.

switch virtual domain 10
switch 1 priority 110
switch 2 priority 100
exit

Turn on virtual mode
Even you have configured the two chassis the virtual switching system is not activated until both switches are operating in virtual mode.
Before virtual mode even when you have done the VSS configuration:

CSW-02#switch read switch_num local
Read SWITCH_NUMBER from Active rommon is 0

Turn on the first switch virtual mode:

CSW-01#switch convert mode virtual

Then turn on the second switch virtual mode:

CSW-02#switch convert mode virtual

When you activate virtual mode command you will see these on both 6509 chassis:
The first switch:

This command will convert all interface names
to naming convention "interface-type switch-number/slot/port",
save the running config to startup-config and
reload the switch.

NOTE: Make sure to configure one or more dual-active detection methods
once the conversion is complete and the switches have come up in VSS mode.

Do you want to proceed? [yes/no]: yes
Converting interface names
Building configuration...
[OK]
Saving converted configuration to bootdisk: ...
Destination filename [startup-config.converted_vs-20121221-025241]?

The second switch:

CSW-02#switch convert mode virtual

This command will convert all interface names
to naming convention "interface-type switch-number/slot/port",
save the running config to startup-config and
reload the switch.

NOTE: Make sure to configure one or more dual-active detection methods
once the conversion is complete and the switches have come up in VSS mode.

Do you want to proceed? [yes/no]: yes
Converting interface names
Building configuration...
[OK]
Saving converted configuration to bootdisk: ...
Destination filename [startup-config.converted_vs-20121221-025333]?

The switch will take a long time to reboot, just have to wait patiently.

After it reboots successfully, the active 6509 will also have to wait for the standby 6509 to finish rebooting, otherwise no configuration can be executed on the active chassis.

VSS Verification

CSW-01#sh switch virtual
Switch mode                  : Virtual Switch
Virtual switch domain number : 10
Local switch number          : 1
Local switch operational role: Virtual Switch Active
Peer switch number           : 2
Peer switch operational role : Virtual Switch Standby
CSW-01#

You must see active and standby, if you only see one active that means the configuration for the standby switch is incorrect and could not become part of VSS pair. This is usually the case when you did not assign VSL on the port-channel successfully, if you cannot assign VSL on the port channel successfully it might be because you set the switch priority before creating VSL.

After the VSS switches rebooted, the active switch ROMMON will have 1.

CSW-01#switch read switch_num local
Read SWITCH_NUMBER from Active rommon is 1
CSW-01#
Advertisements
This entry was posted in High Availability and tagged , , , . Bookmark the permalink.

2 Responses to Cisco Systems: Virtual Switching System

  1. Pingback: Palo Alto Networks: OSPF and L3 Link aggregation | The Network Journal

  2. Pingback: Palo Alto Networks: Active/Active High Availability | The Network Journal

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s