Hot standby router protocol (HSRP): Recovery / failover time test

Diagram for HSRP test plan

2x 1841 routers were configured using HSRPv2. 2x 3750 switches were stacked as a single entity. Loopback interface was configured for each 1841 router for loopback reachability test.

Test objective and test procedures
Both 1841 routers were configured HSRPv2 for redundancy. Vlan 10 is tested in this test plan to demonstrate the failover time when a link failed between router and switch.

Catalyst 3750 switches were stacked together as a single entity, two links were connected to different 1841 routers, vlan 10 was elected to test HSRP performance.

A pc was connected to the stacked 3750, and was assigned a vlan 10 member, the pc ping to both loopback interfaces of the routers.

A link between the router and switch would be removed, the recovery time would be timed and recorded. Test would be performed with RSTP enabled and with RSTP/STP disabled.

HSRP configuration in vlan 10 of both routers

FHRP-1#
!
interface FastEthernet0/1.10
 encapsulation dot1Q 10
 ip address 192.168.10.1 255.255.255.0
 ip router isis
 standby version 2
 standby 10 ip 192.168.10.3
 standby 10 timers msec 500 msec 1500
 standby 10 priority 110
 standby 10 preempt
 standby 10 track 1 decrement 20
end

track 1 interface FastEthernet0/1 line-protocol

router isis
 net 49.0001.0000.0000.0001.00
 is-type level-1
FHRP-2#
!
interface FastEthernet0/1.10
 encapsulation dot1Q 10
 ip address 192.168.10.2 255.255.255.0
 ip router isis
 standby version 2
 standby 10 ip 192.168.10.3
 standby 10 timers msec 500 msec 1500
 standby 10 preempt
end
router isis
 net 49.0001.0000.0000.0002.00
 is-type level-1

HSRP when all is normal

There was no downtime during normal operation.

HSRP with RSTP enabled, link between router and switch removed

Rapid PVST+ was enabled on 3750 stacked switches. When a link was removed, there was 7 second blackhole when trying to reach 192.168.100.150, and 1 sec blackhole when trying to reach 192.168.100.151.
If default STP was used the downtime would be longer than this.

HSRP with RSTP enabled, link reinstated

The long downtime was due to RSTP, the downtime was between 13 seconds and 28 seconds.

Switch#sh spanning vlan 10

VLAN0010
  Spanning tree enabled protocol rstp
  Root ID    Priority    32778
             Address     0013.c3f1.8d00
             This bridge is the root
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32778  (priority 32768 sys-id-ext 10)
             Address     0013.c3f1.8d00
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  300 sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Fa1/0/1             Desg FWD 19        128.3    P2p
Fa1/0/5             Desg FWD 19        128.7    P2p
Fa2/0/1             Desg BLK 19        128.57   P2p


Switch#sh spanning vlan 10

VLAN0010
  Spanning tree enabled protocol rstp
  Root ID    Priority    32778
             Address     0013.c3f1.8d00
             This bridge is the root
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32778  (priority 32768 sys-id-ext 10)
             Address     0013.c3f1.8d00
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  300 sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Fa1/0/1             Desg FWD 19        128.3    P2p
Fa1/0/5             Desg FWD 19        128.7    P2p
Fa2/0/1             Desg LRN 19        128.57   P2p


Switch#
*Mar  1 14:22:15.144: %SW_MATM-4-MACFLAP_NOTIF: Host 0000.0c9f.f00a in vlan 10 is flapping between port Fa2/0/1 and port Fa1/0/1
Switch#
*Mar  1 14:22:20.001: %SW_MATM-4-MACFLAP_NOTIF: Host 0000.0c9f.f00a in vlan 10 is flapping between port Fa1/0/1 and port Fa2/0/1
Switch#sh spanning vlan 10

VLAN0010
  Spanning tree enabled protocol rstp
  Root ID    Priority    32778
             Address     0013.c3f1.8d00
             This bridge is the root
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32778  (priority 32768 sys-id-ext 10)
             Address     0013.c3f1.8d00
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  300 sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Fa1/0/1             Desg FWD 19        128.3    P2p
Fa1/0/5             Desg FWD 19        128.7    P2p
Fa2/0/1             Desg FWD 19        128.57   P2p


Switch#

While the RSTP state was transiting from blocking to learning and from learning to forwarding no data was sent and received this increased the downtime of the supposedly fast HSRP. Fortunately forward delay has no effect on RSTP so when the RSTP state changed to forwarding the data resumed forwarding immediately.

Disable spanning tree on the tested vlan

Issue no spanning-tree vlan 10 to disable spanning tree from vlan 10, since there is no layer 2 loop disabling spanning tree will not be a problem.

Disable spanning tree from vlan 10, link between switch and router removed.

When the link was reinstated the downtime was negligible, only 30ms.

Advertisements
This entry was posted in High Availability and tagged , , , , . Bookmark the permalink.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s