Intermediate System-Intermediate System Basics

Conditions to form IS-IS adjacency

1. MTU must match.

2. IS level must match. Level 1 and level 1 router can form adjacency, level 1 router can form adjacency with level1/2 router this is because this router has two IS databases and one is level 1 database. Level 2 and level 2 router can form adjacency, level 2 router also forms adjacency with level1/2 router.

3. If level 1 router, area id must match.

4. If authentication is configured, IS-IS authentication must match.

5. IS system ID must be unique, no overlapping is allowed.

Terminology

1. Intermediate system is the router.

2. End system is the host.

Network service access point (NSAP) format

The most common format I encountered is AFI.AreaID.SystemID.N-selector format, which is about 10-byte long.

If the NET is private then AFI is 49.

There are three techniques to create system ID:

1. Use any number.

2. Use mac address.

3. use IP address and pad the ip address with 0 to make up a 6-byte system ID. Example: IPv4 address 192.168.1.1 -> 192.168.001.001 -> 1921.6800.1001.

Single area IS-IS

R1:

!
interface Loopback0
 ip address 192.168.1.1 255.255.255.255
!
interface Loopback1
 ip address 10.0.1.1 255.255.255.0
 ip router isis 
!
interface Loopback2
 ip address 10.0.2.1 255.255.255.0
 ip router isis 
!
!
interface Serial0/0
 bandwidth 2000
 ip address 192.168.0.1 255.255.255.252
 ip router isis 
 clock rate 2000000
!
interface Serial0/1
 bandwidth 2000
 ip address 192.168.0.9 255.255.255.252
 ip router isis 
 clock rate 2000000
!
router isis 
 net 49.0001.1921.6800.1001.00
 is-type level-1
!

R2:

!
interface Loopback0
 ip address 192.168.2.2 255.255.255.255
!
interface Serial0/0
 bandwidth 2000
 ip address 192.168.0.2 255.255.255.252
 ip router isis 
!
interface Serial0/1
 bandwidth 2000
 ip address 192.168.0.5 255.255.255.252
 ip router isis 
 clock rate 2000000
!
router isis 
 net 49.0001.1921.6800.2002.00
 is-type level-1
!

R3:

!
interface Loopback0
 ip address 192.168.3.3 255.255.255.255
!
interface Serial0/0
 bandwidth 2000
 ip address 192.168.0.6 255.255.255.252
 ip router isis 
!
interface Serial0/1
 bandwidth 2000
 ip address 192.168.0.10 255.255.255.252
 ip router isis 
!
router isis 
 net 49.0001.1921.6800.3003.00
 is-type level-1
!

Verification
From R2:


R2#sh ip route isis
     10.0.0.0/24 is subnetted, 2 subnets
i L1    10.0.2.0 [115/20] via 192.168.0.1, Serial0/0
i L1    10.0.1.0 [115/20] via 192.168.0.1, Serial0/0
     192.168.0.0/30 is subnetted, 3 subnets
i L1    192.168.0.8 [115/20] via 192.168.0.6, Serial0/1
                    [115/20] via 192.168.0.1, Serial0/0
R2#

R2#ping 10.0.2.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.2.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/27/72 ms
R2#ping 10.0.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/32/84 ms
R2#
Advertisements
This entry was posted in IS-IS, Route and tagged , . Bookmark the permalink.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google+ photo

You are commenting using your Google+ account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

w

Connecting to %s