Arch Linux: Error occurs no packages were upgraded.

Contains two error:

1. /etc/mtab exits in filesystem

2. /etc/profile.d/locale.sh exits in filesystem

General solution is to do pacman -Syu –force.

It seemed previously failure to install anything useful in openbox were due to these two errors. After I did a force upgrade, problem resolved and I can install useful tools onto openbox.

Advertisements
This entry was posted in Linux, System OS and tagged , , , . Bookmark the permalink.

One Response to Arch Linux: Error occurs no packages were upgraded.

  1. Lactury says:

    When i try, I get this:

    warning: /etc/locale.gen installed as /etc/locale.gen.pacnew
    error: extract: not overwriting dir with file lib
    error: problem occurred while upgrading glibc
    call to execv failed (No such file or directory)
    error: command failed to execute correctly
    error: could not commit transaction
    error: failed to commit transaction (transaction aborted)
    Errors occurred, no packages were upgraded.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s