Tshoot: High CPU utilization while flexlink and multicast were operating.

Simple topology to demonstrate problem with this design using flexlink

Equipments and tools

1. Windows 2003 server with Orion NPM installed. For traffic and network health monitoring.

2. Windows XP with VLC media player version 0.8.6c, this is the video server.

3. Windows 7 with VLC media player version 0.8.6c, this is the video client.

4. One WS-3560-24TS-E, Catalyst switch that has flexlink feature.

5. One Cisco 871 router with built in 4-port switch.

Video server will be connected at fa4 of 871, and Orion server as well as video client will be connected at vlan 100 located at 3560.

Orion server is 192.168.100.254/24, video client is 192.168.100.200 and video server is 10.10.10.1

PIM sparse mode was used for this demonstration.

Motivation for this demonstration

From Cisco docs, caution should be exercised when using flexlink, user has to make sure the topology has no loop. I interpreted this clause as, as long as, there’s no additional cable connecting to a non-flexlink port to form a loop there should be no bridging loop, because flexlink standby is in discarding state and flexlink active is in forwarding state. This is not true when I use multicast to stream one video source to one video client in Vlan 100. CPU utilization for 871 and 3560 were at between 4-6% while the flexlink standby port was not connected, but when I connected the flexlink pair CPU utilization for 871 and 3560 began to increase gradually. Using Orion NPM to monitor MC traffic, found that there’s no surge of MC traffic throughout the demonstration, but process cpu and orion graph indicated that there’s an increasing load to the cpu. My colleague called TAC and sent the TAC an email he kept stressing about STP….-_-” Did he mean flexlink can cause bridging loop even if no additional cable was connected to create a loop? If this was what he meant then he indirectly said flexlink standby was forwarding and not discarding. TAC kept stressing STP STP STP until I was really fed up….I knew well flexlink pair was not participating STP, but there’s only one pair of flexlink connected upstream to 800 series router’s 4-port switch… I would try not to contact Cisco TAC again….People from supportforum.cisco.com gave better advice than this TAC… -_-” Anyway….nevermind…

r871 configuration preparation for this demonstration

interface Vlan100
ip address 192.168.100.2 255.255.255.0
ip pim sparse-mode
end

ip pim rp-address 192.168.100.1

interface FastEthernet4
ip address 10.10.10.1 255.255.255.0
ip pim sparse-mode
duplex auto
speed auto
end

snmp-server view filter iso included
snmp-server view filter at excluded
snmp-server view filter internet.6.3.15 excluded
snmp-server view filter internet.6.3.16 excluded
snmp-server view filter internet.6.3.18 excluded
snmp-server view filter ip.21 excluded
snmp-server view filter ip.35 excluded
snmp-server community public RO orion-server

ip access-list standard orion-server
permit 192.168.100.254

interface FastEthernet0
switchport mode trunk
end

interface FastEthernet1
switchport mode trunk
end

3560-2 configuration preparation for this demonstration

snmp-server view filter iso included
snmp-server view filter at excluded
snmp-server view filter snmpUsmMIB excluded
snmp-server view filter snmpVacmMIB excluded
snmp-server view filter snmpCommunityMIB excluded
snmp-server view filter ip.21 excluded
snmp-server view filter ip.35 excluded
snmp-server community public RO orion-server

ip access-list standard orion-server
permit 192.168.100.254

interface Vlan100
ip address 192.168.100.1 255.255.255.0
ip pim sparse-mode
end

ip pim rp-address 192.168.100.1

ip route 10.10.10.0 255.255.255.0 192.168.100.2

interface FastEthernet0/1
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 100
switchport mode trunk
switchport nonegotiate
switchport backup interface Fa0/2
switchport backup interface Fa0/2 preemption mode forced
switchport backup interface Fa0/2 preemption delay 30
end

Before flexlink pair was fully connected i.e. only flexlink active was connected

Before flexlink pair was fully connected; only flexlink active was connected. From Orion NPM. The snmp polling was 30seconds.

3560 process cpu before flexlink pair was fully connected; only flexlink active was connected.

Cisco 871 router process cpu before flexlink pair was fully connected; only flexlink active was connected.

After flexlink pair was connected i.e. both flexlink active and standby were connected

3560 process cpu after flexlink was fully connected.

3560 cpu load increasing after flexlink pair was fully connected.

3560 CPU load increasing after flexlink was fully connected.

Cisco 871 cpu load increasing gradually after flexlink pair was fully connected.

3560 CPU usage 25minutes later.

Cisco 871 cpu usage 27 minutes later.

Cisco 871 router cpu load 27minutes later.

3560 cpu load 33 minutes later.

 

3560 CPU load decreasing after flexlink standby port was shutdown

There's a decrease in CPU usage after the flexlink standby port was shutdown

3560 cpu usage was further decreased after flexlink standby port was shutdown

From Orion NPM, CPU load decreased after flexlink standby port was shutdown

MC traffic in vlan 100 (3560) throughout the demonstration

3560 bufferand interface statistics throughout the demonstration.

Cisco 871 router CPU load after flexlink standby port was shut down

871 cpu load decreased after flexlink standby port was shutdown

871 buffer and interface statistics throughout the demonstration

871 mc traffic throughout the demonstration

Advertisements
This entry was posted in IP Multicast, Switch, Tshoot and tagged , , , , , , , , . Bookmark the permalink.

2 Responses to Tshoot: High CPU utilization while flexlink and multicast were operating.

  1. laxman says:

    kindly suggest some websites,books and simulators for learning routing and switching.

  2. cyruslab says:

    I do not use simulators nor do I read books for troubleshooting. I use real equipments for lab. You can try GNS3 for doing router emulation. As for books I read Routing TCP/IP volume 1.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google+ photo

You are commenting using your Google+ account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

w

Connecting to %s