BGP: Load balancing using ebgp multihop and loopback interface.

Border routers of two AS having two serial links with equal bandwidth, normally ebgp will choose one path to send traffic, using ebgp multihop with loopback interface can achieve load sharing between these links.

1841-1 configuration

1841-1#sh run | s router bgp

router bgp 64512

no synchronization

bgp log-neighbor-changes

network 172.16.1.0 mask 255.255.255.0

neighbor 110.1.1.1 remote-as 64513

neighbor 110.1.1.1 ebgp-multihop 2

neighbor 110.1.1.1 update-source Loopback64512

no auto-summary

1841-1#sh run | i ip route
ip route 110.1.1.1 255.255.255.255 192.168.1.2
ip route 110.1.1.1 255.255.255.255 192.168.2.2

1841-2 Configuration

1841-2#sh run | s router bgp
router bgp 64513
no synchronization
bgp log-neighbor-changes
network 10.1.1.0 mask 255.255.255.0
neighbor 100.1.1.1 remote-as 64512
neighbor 100.1.1.1 ebgp-multihop 2
neighbor 100.1.1.1 update-source Loopback64513
no auto-summary

1841-2#sh run | i ip route
ip route 100.1.1.1 255.255.255.255 192.168.1.1
ip route 100.1.1.1 255.255.255.255 192.168.2.1

Verification

1841-1#traceroute 10.1.1.1

Type escape sequence to abort.
Tracing the route to 10.1.1.1

1 192.168.2.2 0 msec
192.168.1.2 0 msec *
1841-1#traceroute 10.1.1.1 numeric

Type escape sequence to abort.
Tracing the route to 10.1.1.1

1 192.168.1.2 0 msec
192.168.2.2 4 msec *

1841-2#traceroute 172.16.1.1 numeric

Type escape sequence to abort.
Tracing the route to 172.16.1.1

1 192.168.2.1 0 msec
192.168.1.1 4 msec *
1841-2#traceroute 172.16.1.1 numeric

Type escape sequence to abort.
Tracing the route to 172.16.1.1

1 192.168.1.1 0 msec
192.168.2.1 0 msec *

Reference: http://www.cisco.com/en/US/tech/tk365/technologies_tech_note09186a00800c95bb.shtml#ebgpmulithoploadbal

Advertisements
This entry was posted in BGP, Route and tagged , , , . Bookmark the permalink.

One Response to BGP: Load balancing using ebgp multihop and loopback interface.

  1. Shahed Israr says:

    nice post. I can not understand what is the difference between maximum-paths & ebgp-multihop command. Any one can explained it ? Here is a another post about eBGP load balancing with single-homed BGP environment & two ISP connected through Static route.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google+ photo

You are commenting using your Google+ account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

w

Connecting to %s