BGP: update source

Just a note to remind myself that to establish eBGP connection if loopback is used as the source then neighbor <peer’s ip address> update-source loopback<id>is necessary.

By default BGP will use the interface ip as the source address to establish TCP connection. If update-source is not used then the BGP adjacency will never be formed, and will always stuck in Active state.

Active state is the state whereby a router is attempting to establish a TCP connection to the destination.

Think of the remote BGP router as a server which is constantly listening to port 179, my local BGP router needs to establish a tcp connection to destination port 179 and start the 3-way handshake, at least one BGP router must have an update-source statement in order to establish adjacency.

Here’s the commands:

1841-2#sh run | s router bgp
router bgp 200
no synchronization
bgp log-neighbor-changes
neighbor 1.1.1.1 remote-as 100
neighbor 1.1.1.1 ebgp-multihop 2
neighbor 1.1.1.1 update-source Loopback200
no auto-summary

1841-1#sh run | i ip route
ip route 2.2.2.2 255.255.255.255 172.2.10.2

1841-1#sh run | s router bgp
router bgp 100
no synchronization
bgp log-neighbor-changes
neighbor 2.2.2.2 remote-as 200
neighbor 2.2.2.2 ebgp-multihop 2
neighbor 2.2.2.2 update-source Loopback100
no auto-summary

1841-2#sh run | i ip route
ip route 1.1.1.1 255.255.255.255 172.2.10.1

My mistake here is I have forgotten to use update-source keyword! Deadly mistake!

Advertisements
This entry was posted in BGP, Route and tagged . Bookmark the permalink.

3 Responses to BGP: update source

  1. Amit Raj says:

    Hi Cyrus,

    I am preparing for CCNP ROUTE exam.

    The update-source is required only if you are using loopback interface address as the neighbour BGP address? If we use the interface address, then this “update-source” command is not required right?

    Thanks for this wonderful site.
    Amit Raj

    • cyruslab says:

      Hi,

      You are right.
      by default BGP speaker advertises its interface IP address as the source address, however if you use loopback address as the source address you need to use update-source command, and your loopback must be reachable by other BGP speakers.

  2. Amit Raj says:

    Sir,

    That means we have to advertise the loop back interface ip addresses which we created in different BGP speakers via IGP like OSPF or EIGRP?

    That is also a difficult task.. 😦

    Thank you very much for the reply.

    Amit.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google+ photo

You are commenting using your Google+ account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s