OSPF: Special area types

Area types planning

Area 0 is backbone area.

Reason: Backbone area being also the transit area should contain all LSA types.

Area 1 and Area 2 are stub OSPF areas.

Reason: There’s only one ASBR, and only 2651-2 has connection to ASBR 2651-4, hence all areas only need to know how to get to 2651-2 to exit OSPF autonomous system. Type 4 and 5 LSAs are not needed to propagate within Area 1 and 2.

Area 4 is Totally Stubby area.

Area 4 has only one exit point to exit out of Area 4 (exit point is ABR 2651-1), hence if exit out of area 4 is needed knowing how to get to 2651-1 is sufficient, also knowing how to get to ASBR is not necessary as 2651-1 has an interface connected to Area 0 which has all LSA types. Hence type 3, 4 and 5 except for type 3 default route are not needed.

Area 3 is Totally stubby NSSA.

One ASBR exists which connects to EIGRP network, however to do inter-area routing Area 3 only needs to know how to get to 2651-2, hence type 3, 4 and 5 LSAs are not needed, 2651-4 will generate type 7 LSAs within Area 3 only.

 

Passive interfaces planning

fa0/1 of 2651-5

fa0/1 1841-2

Reason: No OSPF routers are connected to these interfaces, hence sending hello packet out to these interfaces is not necessary.

Routing loop prevention planning

2651-2 should filter redistributed external OSPF from entering into EIGRP again.

2651-2 should filter redistributed external EIGRP from entering into OSPF again.

 

2651-1 Configuration

2651-1#sh run | s router ospf
router ospf 1
router-id 22.22.22.22
log-adjacency-changes
area 1 stub
area 4 stub no-summary
network 2.2.2.2 0.0.0.0 area 0
network 10.100.1.1 0.0.0.0 area 4
network 172.16.10.2 0.0.0.0 area 0
network 172.16.10.9 0.0.0.0 area 0
network 192.168.1.1 0.0.0.0 area 1

 

2651-5 Configuration

2651-5#sh run | s router
router ospf 1
router-id 66.66.66.66
log-adjacency-changes
area 4 stub
passive-interface default
no passive-interface Serial0/0
network 10.100.1.2 0.0.0.0 area 4

 

2651-3 Configuration

2651-3#sh run | s router
router ospf 1
router-id 44.44.44.44
log-adjacency-changes
area 1 stub
area 2 stub
network 4.4.4.4 0.0.0.0 area 1
network 192.168.1.2 0.0.0.0 area 1
network 192.168.1.6 0.0.0.0 area 2

 

2651-2 Configuration

2651-2#sh run | s router
router ospf 1
router-id 33.33.33.33
log-adjacency-changes
area 2 stub
area 3 nssa no-summary
network 3.3.3.3 0.0.0.0 area 0
network 172.16.10.6 0.0.0.0 area 0
network 172.16.10.10 0.0.0.0 area 0
network 172.17.10.1 0.0.0.0 area 3
network 192.168.1.5 0.0.0.0 area 2

 

2651-4 Configuration

2651-4#sh run | s router
router eigrp 90
redistribute ospf 1 metric 128 2000 255 1 1500
passive-interface default
no passive-interface FastEthernet0/0
network 172.18.10.1 0.0.0.0
no auto-summary
router ospf 1
router-id 55.55.55.55
ignore lsa mospf
log-adjacency-changes
area 3 nssa
redistribute eigrp 90 metric 10 subnets tag 90
network 172.17.10.2 0.0.0.0 area 3

 

1841-2 configuration

1841-2#sh run | s router
router eigrp 90
passive-interface default
no passive-interface FastEthernet0/0
network 172.18.10.2 0.0.0.0
no auto-summary

 

There is a potential routing loop when redistributing EIGRP into OSPF, a proper route map for both protocols has not been configured completely.

Advertisements
This entry was posted in OSPF, Route and tagged , . Bookmark the permalink.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s