OSPF: non-broadcast multiaccess network (non-broadcast type)

OSPF network types

1. Point-to-point: Network between a pair of routers.

2. Broadcast multiaccess: If you connect the routers to a switch, the switch is broadcast capable. OSPF over EoMPLS behaves the same as broadcast multiaccess, OSPF routers do not know the existence of EoMPLS at all. DR is required, BDR can be elected if chosen.

3. Non-broadcast multiaccess: A network that connects more than two routers but without broadcast capability such as frame relay, ATM, X.25. DR is required, BDR can be elected if chosen.

This lab will explore the behaviour of OSPF in NBMA network using Cisco mode and RFC compliant mode. In this NBMA network there’s no need to configure ospf, this lab is to show OSPF behaviour for different network types. Ignore the discontiguous area 3 which I have configured for OSPF via FR. If area 3 is needed to connect to Area 0 a GRE tunnel can be established to extend area 3 to area 0.

Cisco’s recommendation is not to have more than 50 routers per area, and not more than 3 interfaces on every area for one OSPF router. I reckon that GRE tunnel is considered an interface.

RFC 2328 compliant method: non-broadcast type

OSPF adjacency has to be manually configured.

Non-broadcast is the default type for multipoint FR in accordance to RFC.

DR and BDR must be elected.

Typically for full mesh or partial mesh topology.

Hello packet sent by OSPF router in non-broadcast network is every 30 seconds.

Here’s the debug output for 2651-3 when adjacency was established using neighbor command.

*Sep 19 11:06:56.444: OSPF: Neighbor change Event on interface Serial0/0.102
*Sep 19 11:06:56.444: OSPF: DR/BDR election on Serial0/0.102
*Sep 19 11:06:56.444: OSPF: Elect BDR 55.55.55.55
*Sep 19 11:06:56.444: OSPF: Elect DR 44.44.44.44
*Sep 19 11:06:56.444:        DR: 44.44.44.44 (Id)   BDR: 55.55.55.55 (Id)

*Sep 19 11:10:46.201: OSPF: Send hello to 10.100.1.3 area 3 on Serial0/0.102 from 10.100.1.1

*Sep 19 11:10:56.453: OSPF: Rcv hello from 55.55.55.55 area 3 from Serial0/0.102 10.100.1.3

*Sep 19 11:10:56.453: OSPF: End of hello processing

2651-5 debug output:

2651-5#
*Mar  2 11:40:18.614: OSPF: Starting 0.0.0.0 address 10.100.1.1 on Serial0/0.201
2651-5#
*Mar  2 11:40:19.319: %SYS-5-CONFIG_I: Configured from console by console
2651-5#
*Mar  2 11:40:24.636: OSPF: Rcv hello from 44.44.44.44 area 3 from Serial0/0.201 10.100.1.1
*Mar  2 11:40:24.636: OSPF: Send immediate hello to nbr 44.44.44.44, src address 10.100.1.1, on Serial0/0.201
*Mar  2 11:40:24.636: OSPF: Send hello to 10.100.1.1 area 3 on Serial0/0.201 from 10.100.1.2
*Mar  2 11:40:24.636: OSPF: End of hello processing
*Mar  2 11:40:24.664: OSPF: Rcv DBD from 44.44.44.44 on Serial0/0.201 seq 0x11DD opt 0x52 flag 0x7 len 32  mtu 1500 state INIT
*Mar  2 11:40:24.664: OSPF: 2 Way Communication to 44.44.44.44 on Serial0/0.201, state 2WAY
*Mar  2 11:40:24.664: OSPF: Nbr state is 2WAY
2651-5#
*Mar  2 11:40:29.664: OSPF: Rcv DBD from 44.44.44.44 on Serial0/0.201 seq 0x11DD opt 0x52 flag 0x7 len 32  mtu 1500 state 2WAY
*Mar  2 11:40:29.664: OSPF: Nbr state is 2WAY
2651-5#
*Mar  2 11:40:34.660: OSPF: Rcv DBD from 44.44.44.44 on Serial0/0.201 seq 0x11DD opt 0x52 flag 0x7 len 32  mtu 1500 state 2WAY
*Mar  2 11:40:34.664: OSPF: Nbr state is 2WAY
2651-5#
*Mar  2 11:40:39.660: OSPF: Rcv DBD from 44.44.44.44 on Serial0/0.201 seq 0x11DD opt 0x52 flag 0x7 len 32  mtu 1500 state 2WAY
*Mar  2 11:40:39.664: OSPF: Nbr state is 2WAY
2651-5#
*Mar  2 11:40:43.647: OSPF: Send hello to 10.100.1.1 area 3 on Serial0/0.201 from 10.100.1.2
2651-5#
*Mar  2 11:40:44.665: OSPF: Rcv DBD from 44.44.44.44 on Serial0/0.201 seq 0x11DD opt 0x52 flag 0x7 len 32  mtu 1500 state 2WAY
*Mar  2 11:40:44.665: OSPF: Nbr state is 2WAY
2651-5#
*Mar  2 11:40:49.661: OSPF: Rcv DBD from 44.44.44.44 on Serial0/0.201 seq 0x11DD opt 0x52 flag 0x7 len 32  mtu 1500 state 2WAY
*Mar  2 11:40:49.665: OSPF: Nbr state is 2WAY
2651-5#
*Mar  2 11:40:54.637: OSPF: Rcv hello from 44.44.44.44 area 3 from Serial0/0.201 10.100.1.1
*Mar  2 11:40:54.637: OSPF: End of hello processing
*Mar  2 11:40:54.665: OSPF: Rcv DBD from 44.44.44.44 on Serial0/0.201 seq 0x11DD opt 0x52 flag 0x7 len 32  mtu 1500 state 2WAY
*Mar  2 11:40:54.665: OSPF: Nbr state is 2WAY
2651-5#
*Mar  2 11:40:59.665: OSPF: Rcv DBD from 44.44.44.44 on Serial0/0.201 seq 0x11DD opt 0x52 flag 0x7 len 32  mtu 1500 state 2WAY
*Mar  2 11:40:59.665: OSPF: Nbr state is 2WAY
*Mar  2 11:42:13.646: OSPF: end of Wait on interface Serial0/0.201
*Mar  2 11:42:13.646: OSPF: DR/BDR election on Serial0/0.201
*Mar  2 11:42:13.646: OSPF: Elect BDR 66.66.66.66
*Mar  2 11:42:13.646: OSPF: Elect DR 44.44.44.44
*Mar  2 11:42:13.646: OSPF: Elect BDR 66.66.66.66
*Mar  2 11:42:13.646: OSPF: Elect DR 44.44.44.44
*Mar  2 11:42:13.646:        DR: 44.44.44.44 (Id)   BDR: 66.66.66.66 (Id)
*Mar  2 11:42:13.646: OSPF: Send DBD to 44.44.44.44 on Serial0/0.201 seq 0x497 opt 0x52 flag 0x7 len 32
*Mar  2 11:42:13.650: OSPF: Send hello to 10.100.1.1 area 3 on Serial0/0.201 from 10.100.1.2
2651-5#
*Mar  2 11:42:13.678: OSPF: Rcv DBD from 44.44.44.44 on Serial0/0.201 seq 0x497 opt 0x52 flag 0x2 len 92  mtu 1500 state EXSTART
*Mar  2 11:42:13.678: OSPF: NBR Negotiation Done. We are the MASTER
*Mar  2 11:42:13.678: OSPF: Send DBD to 44.44.44.44 on Serial0/0.201 seq 0x498 opt 0x52 flag 0x3 len 52
*Mar  2 11:42:13.702: OSPF: Rcv DBD from 44.44.44.44 on Serial0/0.201 seq 0x498 opt 0x52 flag 0x0 len 32  mtu 1500 state EXCHANGE
*Mar  2 11:42:13.702: OSPF: Send DBD to 44.44.44.44 on Serial0/0.201 seq 0x499 opt 0x52 flag 0x1 len 32
*Mar  2 11:42:13.702: OSPF: Send LS REQ to 44.44.44.44 length 36 LSA count 3
*Mar  2 11:42:13.727: OSPF: Rcv LS REQ from 44.44.44.44 on Serial0/0.201 length 36 LSA count 1
*Mar  2 11:42:13.727: OSPF: Send UPD to 10.100.1.1 on Serial0/0.201 length 40 LSA count 1
*Mar  2 11:42:13.731: OSPF: Rcv DBD from 44.44.44.44 on Serial0/0.201 seq 0x499 opt 0x52 flag 0x0 len 32  mtu 1500 state EXCHANGE
*Mar  2 11:42:13.731: OSPF: Exchange Done with 44.44.44.44 on
2651-5# Serial0/0.201
*Mar  2 11:42:13.747: OSPF: Rcv LS UPD from 44.44.44.44 on Serial0/0.201 length 132 LSA count 3
*Mar  2 11:42:13.747: OSPF: Synchronized with 44.44.44.44 on Serial0/0.201, state FULL
*Mar  2 11:42:13.747: %OSPF-5-ADJCHG: Process 1, Nbr 44.44.44.44 on Serial0/0.201 from LOADING to FULL, Loading Done
*Mar  2 11:42:14.251: OSPF: Rcv LS UPD from 44.44.44.44 on Serial0/0.201 length 64 LSA count 1
2651-5#
*Mar  2 11:42:24.640: OSPF: Rcv hello from 44.44.44.44 area 3 from Serial0/0.201 10.100.1.1
*Mar  2 11:42:24.640: OSPF: Neighbor change Event on interface Serial0/0.201
*Mar  2 11:42:24.640: OSPF: DR/BDR election on Serial0/0.201
*Mar  2 11:42:24.640: OSPF: Elect BDR 66.66.66.66
*Mar  2 11:42:24.644: OSPF: Elect DR 44.44.44.44
*Mar  2 11:42:24.644:        DR: 44.44.44.44 (Id)   BDR: 66.66.66.66 (Id)
*Mar  2 11:42:24.644: OSPF: End of hello processing

The full adjacency took 2mins in non-broadcast.

OSPF configuration

2651-3#

interface Serial0/0.102 multipoint
ip address 10.100.1.1 255.255.255.0
ip ospf network non-broadcast
ip ospf priority 10
frame-relay map ip 10.100.1.2 102 broadcast
frame-relay map ip 10.100.1.3 103 broadcast
end

2651-3#
router ospf 1
router-id 44.44.44.44
log-adjacency-changes
network 4.4.4.4 0.0.0.0 area 1
network 10.100.1.1 0.0.0.0 area 3
network 192.168.1.2 0.0.0.0 area 1
network 192.168.1.6 0.0.0.0 area 2
neighbor 10.100.1.2
neighbor 10.100.1.3

2651-4#

interface Serial0/0.301 multipoint
ip address 10.100.1.3 255.255.255.0
ip ospf network non-broadcast
frame-relay map ip 10.100.1.1 301 broadcast
frame-relay map ip 10.100.1.2 301
end

2651-4#
router ospf 1
router-id 55.55.55.55
log-adjacency-changes
network 10.100.1.3 0.0.0.0 area 3
neighbor 10.100.1.1

2651-5#

interface Serial0/0.201 multipoint
ip address 10.100.1.2 255.255.255.0
ip ospf network non-broadcast
frame-relay map ip 10.100.1.1 201 broadcast
frame-relay map ip 10.100.1.3 201
end

2651-5#
router ospf 1
router-id 66.66.66.66
log-adjacency-changes
network 10.100.1.2 0.0.0.0 area 3
neighbor 10.100.1.1

Advertisements
This entry was posted in Frame-relay, OSPF, Route, WAN and tagged , , . Bookmark the permalink.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s