OSPF: non-broadcast multiaccess (point-to-multipoint type)

RFC2328 compliant (point-to-multipoint type)

1. RFC2328 compliant mode.

2. No DR and BDR is/are needed.

3. Multicast OSPF hello packet is sent to discover neighbours.

4. Typically for partial mesh or star topology.

 

Debug output of 2651-4

2651-4#
*Mar  3 11:26:39.841: OSPF: Interface Serial0/0.301 going Up
*Mar  3 11:26:39.841: OSPF: Send hello to 224.0.0.5 area 3 on Serial0/0.301 from 10.100.1.3
*Mar  3 11:26:39.941: OSPF: Rcv hello from 44.44.44.44 area 3 from Serial0/0.301 10.100.1.1
*Mar  3 11:26:39.941: OSPF: 2 Way Communication to 44.44.44.44 on Serial0/0.301, state 2WAY
*Mar  3 11:26:39.941: OSPF: Send DBD to 44.44.44.44 on Serial0/0.301 seq 0x658 opt 0x52 flag 0x7 len 32
*Mar  3 11:26:39.941: OSPF: Send immediate hello to nbr 44.44.44.44, src address 10.100.1.1, on Serial0/0.301
*Mar  3 11:26:39.941: OSPF: Send hello to 10.100.1.1 area 3 on Serial0/0.301 from 10.100.1.3
*Mar  3 11:26:39.941: OSPF: End of hello processing
*Mar  3 11:26:39.965: OSPF: Rcv DBD from 44.44.44.44 on Serial0/0.301 seq 0xB36 opt 0x52 flag 0x7 len 32  mtu 1500 state EXSTART
*Mar  3 11:26:39.965: OSPF: NBR Negotiation Done. We are the SLAVE
*Mar  3 11:26:39.965: OSPF: Send DBD to 44.44.44.44 on Serial0/0.301 seq 0xB36 opt 0x52 flag 0x
2651-4#0 len 32
*Mar  3 11:26:39.989: OSPF: Rcv DBD from 44.44.44.44 on Serial0/0.301 seq 0xB37 opt 0x52 flag 0x3 len 52  mtu 1500 state EXCHANGE
*Mar  3 11:26:39.993: OSPF: Send DBD to 44.44.44.44 on Serial0/0.301 seq 0xB37 opt 0x52 flag 0x0 len 32
*Mar  3 11:26:40.013: OSPF: Rcv DBD from 44.44.44.44 on Serial0/0.301 seq 0xB38 opt 0x52 flag 0x1 len 32  mtu 1500 state EXCHANGE
*Mar  3 11:26:40.013: OSPF: Exchange Done with 44.44.44.44 on Serial0/0.301
*Mar  3 11:26:40.013: OSPF: Send LS REQ to 44.44.44.44 length 12 LSA count 1
*Mar  3 11:26:40.013: OSPF: Send DBD to 44.44.44.44 on Serial0/0.301 seq 0xB38 opt 0x52 flag 0x0 len 32
*Mar  3 11:26:40.037: OSPF: Rcv LS UPD from 44.44.44.44 on Serial0/0.301 length 64 LSA count 1
*Mar  3 11:26:40.041: OSPF: Synchronized with 44.44.44.44 on Serial0/0.301, state FULL
*Mar  3 11:26:40.041: %OSPF-5-ADJCHG: Process 1, Nbr 44.44.44.44 on Serial0/0.301 from LOADING to FULL, Loading Done
*Mar  3 11:26:40.486: %SYS-5-CONFIG_I: Configured from console by console
*Mar  3 11:26:40.546: OSPF: Rcv LS UPD from 44.44.44.44 on Serial0/0.301 length 76 LSA count 1

 

Debug output of 2651-5

2651-5(config-router)#
*Mar  2 17:17:00.086: OSPF: Interface Serial0/0.201 going Up
*Mar  2 17:17:00.086: OSPF: Send hello to 224.0.0.5 area 3 on Serial0/0.201 from 10.100.1.2
*Mar  2 17:17:00.154: OSPF: Rcv hello from 44.44.44.44 area 3 from Serial0/0.201 10.100.1.1
*Mar  2 17:17:00.154: OSPF: 2 Way Communication to 44.44.44.44 on Serial0/0.201, state 2WAY
*Mar  2 17:17:00.154: OSPF: Send DBD to 44.44.44.44 on Serial0/0.201 seq 0x25CF opt 0x52 flag 0x7 len 32
*Mar  2 17:17:00.154: OSPF: Send immediate hello to nbr 44.44.44.44, src address 10.100.1.1, on Serial0/0.201
*Mar  2 17:17:00.154: OSPF: Send hello to 10.100.1.1 area 3 on Serial0/0.201 from 10.100.1.2
*Mar  2 17:17:00.158: OSPF: End of hello processing
*Mar  2 17:17:00.178: OSPF: Rcv DBD from 44.44.44.44 on Serial0/0.201 seq 0x12D3 opt 0x52 flag 0x7 len 32  mtu 1500 state EXSTART
*Mar  2 17:17:00.178: OSPF: First DBD and we are not SLAVE
*Mar  2 17:17:00.190: OSPF: Rcv DBD from 44.44.44.44 on Serial0/0.201 seq 0x25CF opt 0x52 flag 0x2 le
2651-5(config-n 72  mtu 1500 state EXSTART
*Mar  2 17:17:00.190: OSPF: NBR Negotiation Done. We are the MASTER
*Mar  2 17:17:00.190: OSPF: Send DBD to 44.44.44.44 on Serial0/0.201 seq 0x25D0 opt 0x52 flag 0x1 len 32
*Mar  2 17:17:00.214: OSPF: Rcv DBD from 44.44.44.44 on Serial0/0.201 seq 0x25D0 opt 0x52 flag 0x0 len 32  mtu 1500 state EXCHANGE
*Mar  2 17:17:00.214: OSPF: Exchange Done with 44.44.44.44 on Serial0/0.201
*Mar  2 17:17:00.214: OSPF: Send LS REQ to 44.44.44.44 length 24 LSA count 2
*Mar  2 17:17:00.246: OSPF: Rcv LS UPD from 44.44.44.44 on Serial0/0.201 length 124 LSA count 2
*Mar  2 17:17:00.246: OSPF: Synchronized with 44.44.44.44 on Serial0/0.201, state FULL
*Mar  2 17:17:00.246: %OSPF-5-ADJCHG: Process 1, Nbr 44.44.44.44 on Serial0/0.201 from LOADING to FULL, Loading Done
*Mar  2 17:17:00.615: OSPF: Rcv LS UPD from 44.44.44.44 on Serial0/0.201 length 76 LSA count 1
*Mar  2 17:17:00.719: OSPF: Rcv LS UPD from 44.44.44.44 on Serial0/0.201 length 88 LSA count 1router)#end

 

OSPF configuration

2651-3#
interface Serial0/0.102 multipoint
ip address 10.100.1.1 255.255.255.0
ip ospf network point-to-multipoint
ip ospf priority 10
frame-relay map ip 10.100.1.2 102 broadcast
frame-relay map ip 10.100.1.3 103 broadcast
end

2651-3#
router ospf 1
router-id 44.44.44.44
log-adjacency-changes
network 4.4.4.4 0.0.0.0 area 1
network 10.100.1.1 0.0.0.0 area 3
network 192.168.1.2 0.0.0.0 area 1
network 192.168.1.6 0.0.0.0 area 2

 

2651-4#
interface Serial0/0.301 multipoint
ip address 10.100.1.3 255.255.255.0
ip ospf network point-to-multipoint
frame-relay map ip 10.100.1.1 301 broadcast
frame-relay map ip 10.100.1.2 301
end

2651-4#sh run | s router
router ospf 1
log-adjacency-changes
network 10.100.1.3 0.0.0.0 area 3

(best practice is to include the router-id before starting to advertise the desired network, I missed out this portion, so the router’s ID is the real ip address)

 

2651-5#
interface Serial0/0.201 multipoint
ip address 10.100.1.2 255.255.255.0
ip ospf network point-to-multipoint
frame-relay map ip 10.100.1.1 201 broadcast
frame-relay map ip 10.100.1.3 201
end

2651-5#
router ospf 1
router-id 66.66.66.66
log-adjacency-changes
network 10.100.1.2 0.0.0.0 area 3

Advertisements
This entry was posted in Frame-relay, OSPF, Route, WAN and tagged , , , . Bookmark the permalink.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google+ photo

You are commenting using your Google+ account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s