OSPF: non-broadcast multaccess network (broadcast type)

OSPF using broadcast network type over NBMA

1. Uses multicast (224.0.0.5, AllSPFRouter multicast) to automatically discover neighbours, no need to use neighbor command for OSPF router to send hello via unicast.

2. Cisco mode. (non RFC2328-compliant)

3. DR and BDR will be elected.

4. Typically full mesh or partial mesh topology.

5. Hello is sent every 10 second in broadcast network.

 

Debug output of 2651-3

*Sep 19 11:42:02.853: OSPF: Send hello to 224.0.0.5 area 3 on Serial0/0.102 from 10.100.1.1
*Sep 19 11:42:02.881: OSPF: Rcv hello from 55.55.55.55 area 3 from Serial0/0.102 10.100.1.3
*Sep 19 11:42:02.881: OSPF: 2 Way Communication to 55.55.55.55 on Serial0/0.102, state 2WAY
*Sep 19 11:42:02.881: OSPF: Backup seen Event before WAIT timer on Serial0/0.102
*Sep 19 11:42:02.881: OSPF: DR/BDR election on Serial0/0.102
*Sep 19 11:42:02.881: OSPF: Elect BDR 44.44.44.44
*Sep 19 11:42:02.881: OSPF: Elect DR 55.55.55.55
*Sep 19 11:42:02.881: OSPF: Elect BDR 44.44.44.44
*Sep 19 11:42:02.881: OSPF: Elect DR 55.55.55.55
*Sep 19 11:42:02.881:        DR: 55.55.55.55 (Id)   BDR: 44.44.44.44 (Id)
*Sep 19 11:42:02.881: OSPF: Send DBD to 55.55.55.55 on Serial0/0.102 seq 0x162C opt 0
2651-3(config-x52 flag 0x7 len 32
*Sep 19 11:42:02.885: OSPF: Send immediate hello to nbr 55.55.55.55, src address 10.100.1.3, on Serial0/0.102
*Sep 19 11:42:02.885: OSPF: Send hello to 10.100.1.3 area 3 on Serial0/0.102 from 10.100.1.1
*Sep 19 11:42:02.885: OSPF: End of hello processing
*Sep 19 11:42:02.889: OSPF: Rcv hello from 66.66.66.66 area 3 from Serial0/0.102 10.100.1.2
*Sep 19 11:42:02.889: OSPF: 2 Way Communication to 66.66.66.66 on Serial0/0.102, state 2WAY
*Sep 19 11:42:02.889: OSPF: Neighbor change Event on interface Serial0/0.102
*Sep 19 11:42:02.889: OSPF: DR/BDR election on Serial0/0.102
*Sep 19 11:42:02.889: OSPF: Elect BDR 44.44.44.44
*Sep 19 11:42:02.889: OSPF: Elect DR 66.66.66.66
*Sep 19 11:42:02.889:        DR: 66.66.66.66 (Id)   BDR: 44.44.44.44 (Id)
*Sep 19 11:42:02.889: OSPF: Send DBD to 66.66.66.66 on Serial0/0.102 seq 0x68E opt 0x52 flag 0x7 len 32
*Sep 19 11:42:02.889: OSPF: Remember old DR 55.55.55.55 (id)
*Sep 19 11:42:02.889: OSPF: Neighbor change Event on interface Serial0/0.102
*Sep 19 11:42:02.893: OSPF: DR/BDR election on Serial0/0.102
*Sep 19 11:42:02.893: OSPF: Elect BDR 44.44.44.44
*Sep 19 11:42:02.893: OSPF: Elect DR 66.66.66.66
*Sep 19 11:42:02.893:        DR: 66.66.66.66 (Id)   BDR: 44.44.44.44 (Id)
*Sep 19 11:42:02.893: OSPF: Send immediate hello to nbr 66.66.66.66, src address 10.100.1.2, on Serial0/0.102
*Sep 19 11:42:02.893: OSPF: Send hello to 10.100.1.2 area 3 on Serial0/0.102 from 10.100.1.1
*Sep 19 11:42:02.893: OSPF: End of hello processing
*Sep 19 11:42:02.905: OSPF: Rcv DBD from 55.55.55.55 on Serial0/0.102 seq 0x210F opt 0x52 flag 0x7 len 32  mtu 1500 state EXSTART
*Sep 19 11:42:02.909: OSPF: NBR Negotiation Done. We are the SLAVE
*Sep 19 11:42:02.909: OSPF: Send DBD to 55.55.55.55 on Serial0/0.102 seq 0x210F opt 0x52 flag 0x0 len 32
*Sep 19 11:42:02.917: OSPF: Rcv DBD from 66.66.66.66 on Serial0/0.102 seq 0xE7C opt 0x52 flag 0x7 len 32  mtu 1500 state EXSTART
*Sep 19 11:42:02.917: OSPF: NBR Negotiation Done. We are the SLAVE
*Sep 19 11:42:02.917: OSPF: Send DBD to 66.66.66.66 on Serial0/0.102 seq 0xE7C opt 0x52 flag 0x0 len 32
*Sep 19 11:42:02.933: OSPF: Rcv DBD from 55.55.55.55 on Serial0/0.102 seq 0x2110 opt 0x52 flag 0x3 len 52  mtu 1500 state EXCHANGE
*Sep 19 11:42:02.933: OSPF: Send DBD to 55.55.55.55 on Serial0/0.102 seq 0x2110 opt 0x52 flag 0x0 len 32
*Sep 19 11:42:02.945: OSPF: Rcv DBD from 66.66.66.66 on Serial0/0.102 seq 0xE7D opt 0x52 flag 0x3 len 52  mtu 1500 state EXCHANGE
*Sep 19 11:42:02.945: OSPF: Send DBD to 66.66.66.66 on Serial0/0.102 seq 0xE7D opt 0x52 flag 0x0 len 32
*Sep 19 11:42:02.957: OSPF: Rcv DBD from 55.55.55.55 on Serial0/0.102 seq 0x2111 opt 0x52 flag 0x1 len 32  mtu 1500 state EXCHANGE
*Sep 19 11:42:02.957: OSPF: Exchange Done with 55.55.55.55 on Serial0/0.102
*Sep 19 11:42:02.957: OSPF: Send LS REQ to 55.55.55.55 length 12 LSA count 1
*Sep 19 11:42:02.957: OSPF: Send DBD to 55.55.55.55 on Serial0/0.102 seq 0x2111 opt 0x52 flag 0x0 len 32
*Sep 19 11:42:02.965: OSPF: Rcv DBD from 66.66.66.66 on Serial0/0.102 seq 0xE7E opt 0x52 flag 0x1 len 32  mtu 1500 state EXCHANGE
*Sep 19 11:42:02.965: OSPF: Exchange Done with 66.66.66.66 on Serial0/0.102
*Sep 19 11:42:02.969: OSPF: Send LS REQ to 66.66.66.66 length 12 LSA count 1
*Sep 19 11:42:02.969: OSPF: Send DBD to 66.66.66.66 on Serial0/0.102 seq 0xE7E opt 0x52 flag 0x0 len 32
*Sep 19 11:42:02.981: OSPF: Rcv LS UPD from 55.55.55.55 on Serial0/0.102 length 64 LSA count 1
*Sep 19 11:42:02.981: OSPF: Synchronized with 55.55.55.55 on Serial0/0.102, state FULL
*Sep 19 11:42:02.981: %OSPF-5-ADJCHG: Process 1, Nbr 55.55.55.55 on Serial0/0.102 from LOADING to FULL, Loading Done
*Sep 19 11:42:02.993: OSPF: Rcv LS UPD from 66.66.66.66 on Serial0/0.102 length 64 LSA count 1
*Sep 19 11:42:02.993: OSPF: Synchronized with 66.66.66.66 on Serial0/0.102, state FULL
*Sep 19 11:42:02.993: %OSPF-5-ADJCHG: Process 1, Nbr 66.66.66.66 on Serial0/0.102 from LOADING to FULL, Loading Done
*Sep 19 11:42:03.454: OSPF: Rcv LS UPD from 55.55.55.55 on Serial0/0.102 length 64 LSA count 1
*Sep 19 11:42:03.458: OSPF: Rcv hello from 22.22.22.22 area 1 from FastEthernet0/1 192.168.1.1
*Sep 19 11:42:03.458: OSPF: End of hello processing
*Sep 19 11:42:03.462: OSPF: Rcv LS UPD from 66.66.66.66 on Serial0/0.102 length 64 LSA count 1
*Sep 19 11:42:03.550: OSPF: Rcv LS UPD from 55.55.55.55 on Serial0/0.102 length 60 LSA count 1
*Sep 19 11:42:03.562: OSPF: Rcv LS UPD from 66.66.66.66 on Serial0/0.102 length 60 LSA count 1
*Sep 19 11:42:06.767: OSPF: Rcv hello from 66.66.66.66 area 3 from Serial0/0.102 10.100.1.2
*Sep 19 11:42:06.767: OSPF: Neighbor change Event on interface Serial0/0.102
*Sep 19 11:42:06.767: OSPF: DR/BDR election on Serial0/0.102
*Sep 19 11:42:06.767: OSPF: Elect BDR 44.44.44.44
*Sep 19 11:42:06.767: OSPF: Elect DR 66.66.66.66
*Sep 19 11:42:06.767:        DR: 66.66.66.66 (Id)   BDR: 44.44.44.44 (Id)
*Sep 19 11:42:06.767: OSPF: End of hello processingrouter)#end
2651-3#
*Sep 19 11:42:08.358: OSPF: Rcv LS UPD from 55.55.55.55 on Serial0/0.102 length 96 LSA count 2
*Sep 19 11:42:08.803: OSPF: Send hello to 224.0.0.5 area 2 on FastEthernet0/0 from 192.168.1.6
*Sep 19 11:42:09.267: OSPF: Send hello to 224.0.0.5 area 1 on FastEthernet0/1 from 192.168.1.2
2651-3#
*Sep 19 11:42:10.201: %SYS-5-CONFIG_I: Configured from console by console
2651-3#
*Sep 19 11:42:10.561: OSPF: Rcv hello from 55.55.55.55 area 3 from Serial0/0.102 10.100.1.3
*Sep 19 11:42:10.565: OSPF: Neighbor change Event on interface Serial0/0.102
*Sep 19 11:42:10.565: OSPF: DR/BDR election on Serial0/0.102
*Sep 19 11:42:10.565: OSPF: Elect BDR 44.44.44.44
*Sep 19 11:42:10.565: OSPF: Elect DR 66.66.66.66
*Sep 19 11:42:10.565:        DR: 66.66.66.66 (Id)   BDR: 44.44.44.44 (Id)
*Sep 19 11:42:10.565: OSPF: End of hello processing
2651-3#
*Sep 19 11:42:11.928: OSPF: Rcv hello from 33.33.33.33 area 2 from FastEthernet0/0 192.168.1.5
*Sep 19 11:42:11.928: OSPF: End of hello processing
*Sep 19 11:42:12.853: OSPF: Send hello to 224.0.0.5 area 3 on Serial0/0.102 from 10.100.1.1
2651-3#
*Sep 19 11:42:13.458: OSPF: Rcv hello from 22.22.22.22 area 1 from FastEthernet0/1 192.168.1.1
*Sep 19 11:42:13.458: OSPF: End of hello processing
2651-3#u
*Sep 19 11:42:16.784: OSPF: Rcv hello from 66.66.66.66 area 3 from Serial0/0.102 10.100.1.2
*Sep 19 11:42:16.784: OSPF: End of hello processing

 

Debug output for 2651-4

*Mar  3 06:23:03.459: OSPF: Interface Serial0/0.301 going Up
*Mar  3 06:23:03.459: OSPF: Send hello to 224.0.0.5 area 3 on Serial0/0.301 from 10.100.1.3
*Mar  3 06:23:03.540: OSPF: Rcv hello from 44.44.44.44 area 3 from Serial0/0.301 10.100.1.1
*Mar  3 06:23:03.540: OSPF: 2 Way Communication to 44.44.44.44 on Serial0/0.301, state 2WAY
*Mar  3 06:23:03.540: OSPF: Backup seen Event before WAIT timer on Serial0/0.301
*Mar  3 06:23:03.540: OSPF: DR/BDR election on Serial0/0.301
*Mar  3 06:23:03.540: OSPF: Elect BDR 44.44.44.44
*Mar  3 06:23:03.540: OSPF: Elect DR 44.44.44.44
*Mar  3 06:23:03.540:        DR: 44.44.44.44 (Id)   BDR: 44.44.44.44 (Id)
*Mar  3 06:23:03.544: OSPF: Send DBD to 44.44.44.44 on Serial0/0.301 seq 0xAE0 opt 0x52 flag 0x7 len 32
*Mar  3 06:23:03.544: OSPF: End of hello processing
*Mar  3 06:23:03.564: OSPF: Rcv DBD from 44.44.44.44 on Serial0/0.301 seq 0x726 opt 0x52 flag 0x7 len 32  mtu 1500 state EXSTART
*Mar  3 06:23:03.564: OSPF: First DBD and we are not SLAVE
*Mar  3 06:23:03.576: OSPF: Rcv DBD from 44.44.44.44 on Serial0/0.301 seq 0xAE0 opt 0x52 flag 0x2 len 92  mtu 1500 state EXSTART
*Mar  3 06:23:03.576: OSPF: NBR Negotiation Done. We are the MASTER
*Mar  3 06:23:03.580: OSPF: Send DBD to 44.44.44.44 on Serial0/0.301 seq 0xAE1 opt 0x52 flag 0x1 len 32
*Mar  3 06:23:03.600: OSPF: Rcv DBD from 44.44.44.44 on Serial0/0.301 seq 0xAE1 opt 0x52 flag 0x0 len 32  mtu 1500 state EXCHANGE
*Mar  3 06:23:03.604: OSPF: Exchange Done with 44.44.44.44 on Serial0/0.301
*Mar  3 06:23:03.604: OSPF: Send LS REQ to 44.44.44.44 length 36 LSA count 3
*Mar  3 06:23:03.636: OSPF: Rcv LS UPD from 44.44.44.44 on Serial0/0.301 length 132 LSA count 3
*Mar  3 06:23:03.640: OSPF: Synchronized with 44.44.44.44 on Serial0/0.301, state FULL
*Mar  3 06:23:03.640: %OSPF-5-ADJCHG: Process 1, Nbr 44.44.44.44 on Serial0/0.301 from LOADING to FULL, Loading Done
*Mar  3 06:23:03.744: OSPF: Rcv hello from 44.44.44.44 area 3 from Serial0/0.301 10.100.1.1
*Mar  3 06:23:03.744: OSPF: End of hello processing

 

OSPF configuration

2651-3#

interface Serial0/0.102 multipoint
ip address 10.100.1.1 255.255.255.0
ip ospf network broadcast
ip ospf priority 10
frame-relay map ip 10.100.1.2 102 broadcast
frame-relay map ip 10.100.1.3 103 broadcast
end

2651-3#
router ospf 1
router-id 44.44.44.44
log-adjacency-changes
network 4.4.4.4 0.0.0.0 area 1
network 10.100.1.1 0.0.0.0 area 3
network 192.168.1.2 0.0.0.0 area 1
network 192.168.1.6 0.0.0.0 area 2

 

2651-4#
interface Serial0/0.301 multipoint
ip address 10.100.1.3 255.255.255.0
ip ospf network broadcast
frame-relay map ip 10.100.1.1 301 broadcast
frame-relay map ip 10.100.1.2 301
end

2651-4#
router ospf 1
router-id 55.55.55.55
log-adjacency-changes
network 10.100.1.3 0.0.0.0 area 3

 

2651-5#

interface Serial0/0.201 multipoint
ip address 10.100.1.2 255.255.255.0
ip ospf network broadcast
frame-relay map ip 10.100.1.1 201 broadcast
frame-relay map ip 10.100.1.3 201
end

2651-5#
router ospf 1
router-id 66.66.66.66
log-adjacency-changes
network 10.100.1.2 0.0.0.0 area 3

Advertisements
This entry was posted in Frame-relay, OSPF, Route, WAN and tagged , , , . Bookmark the permalink.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s