Connecting Enterprise hub to other enterprise spokes over NBMA (frame-relay)

The original design intention is not to advertise routes using ospf over NBMA network, it is not necessary for this case. However for Buona Vista HQ to be able to reach the two sites, I need entries in the routing table to let other routers know the road map to reach. A way is to let OSPF advertise a default route by using default-information originate always command, this diagram is very straightforward as there’s only one exit point out.

Two ways for 2651-3 to advertise default route

1. If 2651-3 (advertising router) has a default route, advertise the default route within ospf process using default-information originate command.

ip route 0.0.0.0 0.0.0.0 Serial0/0.102

router ospf 1
default-information originate

2. The alternative way is to advertise default route irregardless whether 2651-3 (advertising router) has the default route or not this is accomplished by including the keyword always at the end of default-information originate command.

2651-3(config-router)#default-information originate always

(2651-3 has no default route configured, however this command will tell all SPF routers to send anything that they do not know to 2651-3)

 

1841-1 routing table

1841-1#sh ip route ospf
2.0.0.0/32 is subnetted, 1 subnets
O       2.2.2.2 [110/2] via 172.16.10.2, 09:36:50, FastEthernet0/0
3.0.0.0/32 is subnetted, 1 subnets
O       3.3.3.3 [110/2] via 172.16.10.6, 09:42:42, FastEthernet0/1
4.0.0.0/32 is subnetted, 1 subnets
O IA    4.4.4.4 [110/3] via 172.16.10.2, 07:49:48, FastEthernet0/0
172.16.0.0/30 is subnetted, 3 subnets
O       172.16.10.8 [110/51] via 172.16.10.6, 07:29:41, FastEthernet0/1
[110/51] via 172.16.10.2, 07:29:51, FastEthernet0/0
192.168.1.0/30 is subnetted, 2 subnets
O IA    192.168.1.0 [110/2] via 172.16.10.2, 07:50:53, FastEthernet0/0
O IA    192.168.1.4 [110/2] via 172.16.10.6, 07:51:25, FastEthernet0/1
O*E2 0.0.0.0/0 [110/1] via 172.16.10.6, 00:02:49, FastEthernet0/1
[110/1] via 172.16.10.2, 00:02:49, FastEthernet0/0

The default metric type is E2 which is not incremental. If a destination ip subnet is unknown by 1841-1, it will send it to 2651-3.

 

Configuration to connect Campus cores via FR

2651-3#
router ospf 1
router-id 44.44.44.44
log-adjacency-changes
redistribute connected
network 4.4.4.4 0.0.0.0 area 1
network 192.168.1.2 0.0.0.0 area 1
network 192.168.1.6 0.0.0.0 area 2
default-information originate always

2651-3
interface Serial0/0.102 multipoint
ip address 10.100.1.1 255.255.255.0
frame-relay map ip 10.100.1.2 102 broadcast
frame-relay map ip 10.100.1.3 103 broadcast
end

 

2651-4#
ip route 0.0.0.0 0.0.0.0 10.100.1.1

2651-4#
interface Serial0/0.301 multipoint
ip address 10.100.1.3 255.255.255.0
frame-relay map ip 10.100.1.1 301 broadcast
frame-relay map ip 10.100.1.2 301
end

 

2651-5#
ip route 0.0.0.0 0.0.0.0 10.100.1.1

2651-5#
interface Serial0/0.201 multipoint
ip address 10.100.1.2 255.255.255.0
frame-relay map ip 10.100.1.1 201 broadcast
frame-relay map ip 10.100.1.3 201
end

Advertisements
This entry was posted in Frame-relay, OSPF, Route, WAN and tagged , , . Bookmark the permalink.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google+ photo

You are commenting using your Google+ account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s