Non-broadcast multi-access network

Hub and spoke connectivity over frame relay (NBMA)

 

1. Multipoint NBMA allows one subnet to be used by hub and spoke routers.

2. In contrast to multipoint, point to point link is a subnet hence consumes more IP subnets.

3. Communication between spoke routers can be established via hub router. Both the spoke routers although not directly linked together requires layer2 reachability.

4. Broadcast will not be passed beyond hub router hence to establish a virtual connection between spoke routers via hub router the broadcast keyword is not necessary.

5. Solutions for the communications between spoke routers:

a. Add static frame relay mapping between spoke routers via hub router:

interface Serial0/1/0.201 multipoint
ip address 172.16.124.2 255.255.255.248
frame-relay map ip 172.16.124.3 201
frame-relay map ip 172.16.124.1 201 broadcast
end

The line in red is the static mapping from spoke to spoke router.

b. Change spoke router’s sub interface from multipoint to point to point.

c. Established a static route to destined spoke router with next hop address

ip route 172.16.124.3 255.255.255.255 172.16.124.1

1841-2#ping 172.16.124.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.124.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 84/86/88 ms

1841-2 only has a static frame map to hub router, an ip route was established to reach the spoke router via hub router’s ip address.

interface Serial0/1/0.201 multipoint
ip address 172.16.124.2 255.255.255.248
frame-relay map ip 172.16.124.1 201 broadcast
end

As shown in the sub interface configuration, there’s no frame relay mapping to the next spoke router, connectivity is based on static route.

d. Use dynamic routing protocol to establish connection.

1841-1#sh run | s router
router eigrp 25
passive-interface default
no passive-interface Serial0/1/0.102
network 172.16.124.1 0.0.0.0
no auto-summary

1841-2#sh run | s router
router eigrp 25
passive-interface default
no passive-interface Serial0/1/0.201
network 172.16.124.2 0.0.0.0
no auto-summary

2651-1#sh run | s router
router eigrp 25
passive-interface default
no passive-interface Serial0/0.301
network 172.16.124.3 0.0.0.0
network 192.168.1.1 0.0.0.0
no auto-summary

Split horizon

Split horizon is a mechanism to prevent routing loop which distance vector routing protocol is susceptible to. EIGRP belongs to distance vector routing protocol category. Only IS-IS and OSPF are qualified as link state routing protocol.

Hub router receives routing update from both spoke routers from its own serial 0/1/0.201 sub interface.
Hub routers received routing updates from both spoke routers but never send the updates back to the same sub interface where hub router learned the route from. As a result hub router knows both spoke routers, but both spoke routers only know hub router.

Here’s the hub router’s routing table:

1841-1#sh ip route

172.16.0.0/29 is subnetted, 1 subnets
C       172.16.124.0 is directly connected, Serial0/1/0.102
10.0.0.0/24 is subnetted, 1 subnets
D       10.10.10.0 [90/2297856] via 172.16.124.2, 00:00:05, Serial0/1/0.102
D    192.168.1.0/24 [90/2297856] via 172.16.124.3, 00:48:19, Serial0/1/0.102

I have created loopback interface for both spoke routers to illustrate clearer. Line in red is the loopback network learned from spoke 1, line in blue is the loopback network learned from spoke 2.

Spoke 1’s routing table:

172.16.0.0/29 is subnetted, 1 subnets
C       172.16.124.0 is directly connected, Serial0/1/0.201
10.0.0.0/24 is subnetted, 1 subnets
C       10.10.10.0 is directly connected, Loopback0

Spoke 1 does not know the network of spoke 2, because the update did not send out from hub router.

Spoke 2’s routing table:

2651-1#sh ip route

172.16.0.0/29 is subnetted, 1 subnets
C       172.16.124.0 is directly connected, Serial0/0.301
C    192.168.1.0/24 is directly connected, Loopback0

Spoke 2 does not know the network of spoke 1 as well, the reason is the same.

You can either change the network to point to point or disable split horizon from hub router’s sub interface. In point to point, each p2p link connects to each spoke router, hence update received from spoke router through its own sub interface will be sent out on another sub interface.

Disable split horizon

1841-1(config-subif)#no ip split-horizon eigrp 25

Spoke 1’s routing table after split horizon was disabled

1841-2#sh ip route

172.16.0.0/29 is subnetted, 1 subnets
C       172.16.124.0 is directly connected, Serial0/1/0.201
10.0.0.0/24 is subnetted, 1 subnets
C       10.10.10.0 is directly connected, Loopback0
D    192.168.1.0/24 [90/2809856] via 172.16.124.1, 00:00:27, Serial0/1/0.201

1841-2#ping 192.168.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 84/86/92 ms

2651-1#sh ip route

172.16.0.0/29 is subnetted, 1 subnets
C       172.16.124.0 is directly connected, Serial0/0.301
10.0.0.0/24 is subnetted, 1 subnets
D       10.10.10.0 [90/2809856] via 172.16.124.1, 00:05:19, Serial0/0.301
C    192.168.1.0/24 is directly connected, Loopback0

2651-1#ping 10.10.10.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.10.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 84/86/92 ms

All multipoint configuration

1841-1#sh run int se0/1/0.102
Building configuration…

Current configuration : 209 bytes
!
interface Serial0/1/0.102 multipoint
ip address 172.16.124.1 255.255.255.248
no ip split-horizon eigrp 25
frame-relay map ip 172.16.124.3 103 broadcast
frame-relay map ip 172.16.124.2 102 broadcast
end

1841-1#sh run | s router
router eigrp 25
passive-interface default
no passive-interface Serial0/1/0.102
network 172.16.124.1 0.0.0.0
no auto-summary

1841-2#sh run int se0/1/0.201
Building configuration…

Current configuration : 169 bytes
!
interface Serial0/1/0.201 multipoint
ip address 172.16.124.2 255.255.255.248
frame-relay map ip 172.16.124.3 201
frame-relay map ip 172.16.124.1 201 broadcast
end

1841-2#sh run | s router
router eigrp 25
passive-interface default
no passive-interface Serial0/1/0.201
network 10.10.10.1 0.0.0.0
network 172.16.124.2 0.0.0.0
no auto-summary

2651-1#sh run int se0/0.301
Building configuration…

Current configuration : 167 bytes
!
interface Serial0/0.301 multipoint
ip address 172.16.124.3 255.255.255.248
frame-relay map ip 172.16.124.1 301 broadcast
frame-relay map ip 172.16.124.2 301
end

2651-1#sh run | s router
router eigrp 25
passive-interface default
no passive-interface Serial0/0.301
network 172.16.124.3 0.0.0.0
network 192.168.1.1 0.0.0.0
no auto-summary
2651-1#

Advertisements
This entry was posted in EIGRP, Frame-relay, Route, WAN and tagged , , , . Bookmark the permalink.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s