Maintenance: Routing protocol migration (RIPv2 to OSPF)

West Office1:

West_Office1#sh ip route

Gateway of last resort is not set

172.16.0.0/24 is subnetted, 7 subnets
R       172.16.252.0 [120/1] via 172.16.2.3, 00:00:19, FastEthernet0/1
R       172.16.253.0 [120/1] via 172.16.254.2, 00:00:08, FastEthernet0/0
[120/1] via 172.16.2.3, 00:00:19, FastEthernet0/1
C       172.16.254.0 is directly connected, FastEthernet0/0
R       172.16.251.0 [120/2] via 172.16.254.2, 00:00:08, FastEthernet0/0
[120/2] via 172.16.2.3, 00:00:19, FastEthernet0/1
R       172.16.6.0 [120/1] via 172.16.254.2, 00:00:09, FastEthernet0/0
C       172.16.2.0 is directly connected, FastEthernet0/1
R       172.16.3.0 [120/1] via 172.16.2.3, 00:00:20, FastEthernet0/1

West Office 2:

West_Office2#sh ip route

Gateway of last resort is not set

172.16.0.0/24 is subnetted, 7 subnets
R       172.16.252.0 [120/1] via 172.16.253.3, 00:00:23, Serial0/0
[120/1] via 172.16.6.4, 00:00:19, FastEthernet0/1
C       172.16.253.0 is directly connected, Serial0/0
C       172.16.254.0 is directly connected, FastEthernet0/0
R       172.16.251.0 [120/1] via 172.16.6.4, 00:00:19, FastEthernet0/1
C       172.16.6.0 is directly connected, FastEthernet0/1
R       172.16.2.0 [120/1] via 172.16.254.1, 00:00:00, FastEthernet0/0
[120/1] via 172.16.253.3, 00:00:24, Serial0/0
R       172.16.3.0 [120/1] via 172.16.253.3, 00:00:24, Serial0/0

Central Office:

Central_Office#sh ip route

Gateway of last resort is not set

172.16.0.0/24 is subnetted, 7 subnets
C       172.16.252.0 is directly connected, Serial0/1
C       172.16.253.0 is directly connected, Serial0/0
R       172.16.254.0 [120/1] via 172.16.253.2, 00:00:03, Serial0/0
[120/1] via 172.16.2.1, 00:00:20, FastEthernet0/1
R       172.16.251.0 [120/1] via 172.16.252.4, 00:00:21, Serial0/1
[120/1] via 172.16.3.5, 00:00:27, FastEthernet0/0
R       172.16.6.0 [120/1] via 172.16.253.2, 00:00:03, Serial0/0
[120/1] via 172.16.252.4, 00:00:22, Serial0/1
C       172.16.2.0 is directly connected, FastEthernet0/1
C       172.16.3.0 is directly connected, FastEthernet0/0

East Office 2:

East_Office2#sh ip route

Gateway of last resort is not set

172.16.0.0/24 is subnetted, 7 subnets
C       172.16.252.0 is directly connected, Serial0/1
R       172.16.253.0 [120/1] via 172.16.252.3, 00:00:15, Serial0/1
[120/1] via 172.16.6.2, 00:00:06, FastEthernet0/1
R       172.16.254.0 [120/1] via 172.16.6.2, 00:00:06, FastEthernet0/1
C       172.16.251.0 is directly connected, FastEthernet0/0
C       172.16.6.0 is directly connected, FastEthernet0/1
R       172.16.2.0 [120/1] via 172.16.252.3, 00:00:15, Serial0/1
R       172.16.3.0 [120/1] via 172.16.252.3, 00:00:16, Serial0/1
[120/1] via 172.16.251.5, 00:00:17, FastEthernet0/0

East Office 1:

East_Office1#sh ip route

Gateway of last resort is not set

172.16.0.0/24 is subnetted, 7 subnets
R       172.16.252.0 [120/1] via 172.16.251.4, 00:00:18, FastEthernet0/0
[120/1] via 172.16.3.3, 00:00:02, FastEthernet0/1
R       172.16.253.0 [120/1] via 172.16.3.3, 00:00:02, FastEthernet0/1
R       172.16.254.0 [120/2] via 172.16.251.4, 00:00:18, FastEthernet0/0
[120/2] via 172.16.3.3, 00:00:02, FastEthernet0/1
C       172.16.251.0 is directly connected, FastEthernet0/0
R       172.16.6.0 [120/1] via 172.16.251.4, 00:00:20, FastEthernet0/0
R       172.16.2.0 [120/1] via 172.16.3.3, 00:00:03, FastEthernet0/1
C       172.16.3.0 is directly connected, FastEthernet0/1

Migrating to OSPF progressively:

West Office 1:

West_Office1#sh run | s router ospf 1
router ospf 1
router-id 1.1.1.1
log-adjacency-changes
network 1.1.1.1 0.0.0.0 area 10
network 172.16.2.1 0.0.0.0 area 10
network 172.16.254.1 0.0.0.0 area 10
distance 200

West_Office1#sh run | s int
interface Loopback1
ip address 1.1.1.1 255.255.255.255
interface FastEthernet0/0
ip address 172.16.254.1 255.255.255.0
ip ospf priority 0
duplex auto
speed auto

interface FastEthernet0/1
ip address 172.16.2.1 255.255.255.0
ip ospf priority 0
duplex auto
speed auto

West Office 2:

West_Office2(config-if)#do sh run | s int
interface Loopback2
ip address 2.2.2.2 255.255.255.255
interface FastEthernet0/0
ip address 172.16.254.2 255.255.255.0
ip ospf priority 0
duplex auto
speed auto
interface Serial0/0
ip address 172.16.253.2 255.255.255.0
ip ospf priority 0
no fair-queue
interface FastEthernet0/1
ip address 172.16.6.2 255.255.255.0
ip ospf priority 0
duplex auto
speed auto

West_Office2#sh run | s router ospf 1
router ospf 1
router-id 2.2.2.2
log-adjacency-changes
network 2.2.2.2 0.0.0.0 area 10
network 172.16.6.2 0.0.0.0 area 10
network 172.16.253.2 0.0.0.0 area 10
network 172.16.254.2 0.0.0.0 area 10
distance 200

Central Office:

Central_Office#sh run | s int
interface FastEthernet0/0
ip address 172.16.3.3 255.255.255.0
ip ospf priority 100
duplex auto
speed auto
interface Serial0/0
bandwidth 512
ip address 172.16.253.3 255.255.255.0
ip ospf priority 100
no fair-queue
clock rate 512000
interface FastEthernet0/1
ip address 172.16.2.3 255.255.255.0
ip ospf priority 100
duplex auto
speed auto
interface Serial0/1
bandwidth 512
ip address 172.16.252.3 255.255.255.0
ip ospf priority 100
clock rate 512000

interface Loopback3
ip address 3.3.3.3 255.255.255.255

Central_Office#sh run | s router ospf 1
router ospf 1
router-id 3.3.3.3
log-adjacency-changes
network 3.3.3.3 0.0.0.0 area 10
network 172.16.2.3 0.0.0.0 area 10
network 172.16.3.3 0.0.0.0 area 10
network 172.16.252.3 0.0.0.0 area 10
network 172.16.253.3 0.0.0.0 area 10
distance 200

East Office 2:

East_Office2#sh run | s router ospf 1
router ospf 1
router-id 4.4.4.4
log-adjacency-changes
network 4.4.4.4 0.0.0.0 area 10
network 172.16.6.4 0.0.0.0 area 10
network 172.16.251.4 0.0.0.0 area 10
network 172.16.252.4 0.0.0.0 area 10
distance 200

East_Office2#sh run | s int
interface Loopback4
ip address 4.4.4.4 255.255.255.255
interface FastEthernet0/0
ip address 172.16.251.4 255.255.255.0
ip ospf priority 0
duplex auto
speed auto
interface FastEthernet0/1
ip address 172.16.6.4 255.255.255.0
ip ospf priority 0
duplex auto
speed auto
interface Serial0/1
ip address 172.16.252.4 255.255.255.0
ip ospf priority 0

East Office 1:

East_Office1#sh run | s router ospf 1
router ospf 1
router-id 5.5.5.5
log-adjacency-changes
network 5.5.5.5 0.0.0.0 area 10
network 172.16.3.5 0.0.0.0 area 10
network 172.16.251.5 0.0.0.0 area 10
distance 200

East_Office1#sh run | s int
interface Loopback5
ip address 5.5.5.5 255.255.255.255
interface FastEthernet0/0
ip address 172.16.251.5 255.255.255.0
ip ospf priority 0
duplex auto
speed auto
interface FastEthernet0/1
ip address 172.16.3.5 255.255.255.0
ip ospf priority 0
duplex auto
speed auto

[Resuming connection 1 to 2651-1 … ]
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!.
Success rate is 99 percent (9516/9517), round-trip min/avg/max = 4/5/152 ms

All routers have removed rip route except for West Office 1 router, 1% lost which is 1 packet lost.

West_Office1#
Gateway of last resort is not set

1.0.0.0/32 is subnetted, 1 subnets
C       1.1.1.1 is directly connected, Loopback1
2.0.0.0/32 is subnetted, 1 subnets
O       2.2.2.2 [200/102] via 172.16.2.3, 00:00:03, FastEthernet0/1
3.0.0.0/32 is subnetted, 1 subnets
O       3.3.3.3 [200/2] via 172.16.2.3, 00:00:03, FastEthernet0/1
4.0.0.0/32 is subnetted, 1 subnets
O       4.4.4.4 [200/102] via 172.16.2.3, 00:00:03, FastEthernet0/1
5.0.0.0/32 is subnetted, 1 subnets
O       5.5.5.5 [200/3] via 172.16.2.3, 00:00:03, FastEthernet0/1
172.16.0.0/24 is subnetted, 7 subnets
O       172.16.252.0 [200/101] via 172.16.2.3, 00:00:05, FastEthernet0/1
O       172.16.253.0 [200/101] via 172.16.2.3, 00:00:05, FastEthernet0/1
C       172.16.254.0 is directly connected, FastEthernet0/0
O       172.16.251.0 [200/3] via 172.16.2.3, 00:00:06, FastEthernet0/1
O       172.16.6.0 [200/102] via 172.16.2.3, 00:00:06, FastEthernet0/1
C       172.16.2.0 is directly connected, FastEthernet0/1
O       172.16.3.0 [200/2] via 172.16.2.3, 00:00:06, FastEthernet0/1
West_Office1#

 

5x 2651xm are used for this lab.

Advertisements
This entry was posted in Network Maintenance, OSPF, Route. Bookmark the permalink.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google+ photo

You are commenting using your Google+ account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

w

Connecting to %s