MPLS: Basic configuration

1. Enable CEF (default is on)

2. Configure an IGP (ospf, eigrp, rip or IS-IS)

3. Define label distribution protocol (optional)

4. Assign LDP router-id. (Optional. Highest loopback address is the LDP router’s ID, if loopback not available then highest ip address on physical interface is the router’s id, this command force an interface to be a LDP router id)

5. Configure mpls lable forwarding on interface.

1841-1#sh run | s interface
interface Loopback0
ip address 10.10.10.101 255.255.255.255
interface FastEthernet0/0
ip address 10.10.10.1 255.255.255.252
ip ospf network point-to-point
speed auto
full-duplex
mpls label protocol ldp
mpls ip

1841-1#sh run | s router ospf 1
router ospf 1
router-id 10.10.10.101
log-adjacency-changes
network 10.10.10.1 0.0.0.0 area 0
network 10.10.10.101 0.0.0.0 area 0

c3825#sh run | s interface
interface Loopback0
ip address 10.10.10.102 255.255.255.255
interface GigabitEthernet0/0
ip address 10.10.10.2 255.255.255.252
ip ospf network point-to-point
duplex full
speed auto
media-type rj45
mpls label protocol ldp
mpls ip
interface GigabitEthernet0/1
ip address 10.10.10.6 255.255.255.252
ip ospf network point-to-point
duplex full
speed auto
media-type rj45
mpls label protocol ldp
mpls ip

c3825#sh run | s router ospf 1
router ospf 1
router-id 10.10.10.102
log-adjacency-changes
network 10.10.10.2 0.0.0.0 area 0
network 10.10.10.6 0.0.0.0 area 0
network 10.10.10.102 0.0.0.0 area 0

1841-2#sh run | s interface
interface Loopback0
ip address 10.10.10.103 255.255.255.255
interface FastEthernet0/1
ip address 10.10.10.5 255.255.255.252
ip ospf network point-to-point
speed auto
full-duplex
mpls label protocol ldp
mpls ip

1841-2#sh run | s router ospf 1
router ospf 1
router-id 10.10.10.103
log-adjacency-changes
network 10.10.10.5 0.0.0.0 area 0
network 10.10.10.103 0.0.0.0 area 0

Advertisements
This entry was posted in MPLS, WAN and tagged . Bookmark the permalink.

One Response to MPLS: Basic configuration

  1. Nico says:

    What IOS version is needed to support MPLS on 1841?

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s