Redistribution: Prefix-list and distribution-list

R1(config)#router ospf 1
R1(config-router)#redistribute eigrp 100

R3#sh ip route ospf
O E2 192.168.100.0/24 [110/20] via 192.168.0.1, 00:00:04, Serial0/1

When R1 redistributed EIGRP route into OSPF area 0, default metric and default classful summarization was used. Look at the routing table of R3, only classful subnet is seen, look at the diagram, the 10 networks are not in the routing table of R3, this is because the keyword subnets was not used in the redistribution command, so only networks that have classful mask will be seen.

R1(config-router)#redistribute eigrp 100 metric 100 subnets metric-type 2

After the keyword subnets was used, R3 routing table displays all 10 networks with their respective subnet mask.

R3#sh ip route ospf
10.0.0.0/8 is variably subnetted, 14 subnets, 2 masks
O E2    10.1.3.0/24 [110/100] via 192.168.0.1, 00:00:06, Serial0/1
O E2    10.1.2.0/24 [110/100] via 192.168.0.1, 00:00:06, Serial0/1
O E2    10.1.1.0/24 [110/100] via 192.168.0.1, 00:00:06, Serial0/1
O E2    10.1.0.0/24 [110/100] via 192.168.0.1, 00:00:06, Serial0/1
O E2    10.1.6.0/24 [110/100] via 192.168.0.1, 00:00:06, Serial0/1
O E2    10.1.5.0/24 [110/100] via 192.168.0.1, 00:00:06, Serial0/1
O E2    10.1.4.0/24 [110/100] via 192.168.0.1, 00:00:06, Serial0/1
O E2 192.168.100.0/24 [110/100] via 192.168.0.1, 00:00:06, Serial0/1

R1(config)#router eigrp 100
R1(config-router)#redistribute ospf 1

R2#sh ip route
10.0.0.0/24 is subnetted, 7 subnets
C       10.1.3.0 is directly connected, Loopback3
C       10.1.2.0 is directly connected, Loopback2
C       10.1.1.0 is directly connected, Loopback1
C       10.1.0.0 is directly connected, Loopback0
C       10.1.6.0 is directly connected, Loopback6
C       10.1.5.0 is directly connected, Loopback5
C       10.1.4.0 is directly connected, Loopback4
C    192.168.100.0/24 is directly connected, Serial0/0

No external OSPF route is in the routing table of R2. This is because no metric was specified in the redistribute command, external route redistributed into EIGRP will have an infinite metric if no metric was specified, infinite metric will make EIGRP think that the route is dead.

R1(config-router)#redistribute ospf 1 metric 1000 100 100 100 1500

Redistribute external route into EIGRP has to specify metric which consists of the K values for EIGRP metric algorithm.

Metric in order:

1. Bandwidth

2. Delay

3. Reliability

4. Loading

5. MTU

R2#sh ip route eigrp
10.0.0.0/8 is variably subnetted, 14 subnets, 2 masks
D EX    10.1.11.0/30 [170/3097600] via 192.168.100.1, 00:02:27, Serial0/0
D EX    10.1.10.0/24 [170/3097600] via 192.168.100.1, 00:02:27, Serial0/0
D EX    10.1.9.0/24 [170/3097600] via 192.168.100.1, 00:02:27, Serial0/0
D EX    10.1.8.0/24 [170/3097600] via 192.168.100.1, 00:02:27, Serial0/0
D EX    10.1.11.4/30 [170/3097600] via 192.168.100.1, 00:02:27, Serial0/0
D EX    10.1.11.8/30 [170/3097600] via 192.168.100.1, 00:02:27, Serial0/0
D EX    10.1.7.0/24 [170/3097600] via 192.168.100.1, 00:02:27, Serial0/0
D EX 192.168.0.0/24 [170/3097600] via 192.168.100.1, 00:02:27, Serial0/0

Look at the AD it is 170, this is the default AD for external EIGRP.

Objective 1:

Implement distribute-list filtering in such a way that the OSPF domain only sees odd numbered loopback networks
coming from R2. Any even numbered subnet (including physical networks) should be hidden from OSPF.

This objective is part of the Jeremy’s lab.

R1’s access-list to be used for distribution list

R1(config)#do sh ip access
Standard IP access list dl-list
10 permit 10.1.1.0, wildcard bits 0.0.0.255
20 permit 10.1.3.0, wildcard bits 0.0.0.255
30 permit 10.1.5.0, wildcard bits 0.0.0.255

R1(config)#router eigrp 100

R1(config-router)#distribute-list dl-list out

The strike-off statement is wrong. Keep here for archiving.

R1(config)#router eigrp 100
R1(config-router)#distribute-list dl-list in se0/0

Filter the odd numbered traffic at EIGRP routed interface first, because the traffic will be coming from R2, in R1’s serial 0/0 interface’s perspective the traffic should be coming in.

R3#sh ip route ospf
10.0.0.0/8 is variably subnetted, 10 subnets, 2 masks
O E2    10.1.3.0/24 [110/100] via 192.168.0.1, 00:24:47, Serial0/1
O E2    10.1.1.0/24 [110/100] via 192.168.0.1, 00:24:47, Serial0/1
O E2    10.1.5.0/24 [110/100] via 192.168.0.1, 00:24:47, Serial0/1
O E2 192.168.100.0/24 [110/100] via 192.168.0.1, 00:24:47, Serial0/1

All wrong.R2 lost the external routes.

Do those again.

R1(config)#router ospf 1

R1(config-router)#distribute-list dl-list out

R1’s perspective the traffic is going out of serial 0/1 into the ospf area 0.

R3#sh ip route ospf
10.0.0.0/8 is variably subnetted, 10 subnets, 2 masks
O E2    10.1.3.0/24 [110/100] via 192.168.0.1, 00:01:31, Serial0/1
O E2    10.1.1.0/24 [110/100] via 192.168.0.1, 00:01:31, Serial0/1
O E2    10.1.5.0/24 [110/100] via 192.168.0.1, 00:01:31, Serial0/1

Objective 2:

Implement route-map filtering in such a way that the EIGRP domain does not see routes with a more specific subnet
mask than /24.

R1(config)#ip prefix-list pl-list permit 10.1.0.0/16 le 24

route-map rm-list permit 10
match ip address prefix-list pl-list

My route map did not work because I left out the keyword prefix-list, if this prefix-list keyword is not specified the access-list is used.

R1#sh route-map
route-map rm-list, permit, sequence 10
Match clauses:
ip address prefix-lists: pl-list
Set clauses:
Policy routing matches: 0 packets, 0 bytes

R1#sh ip prefix-list
ip prefix-list pl-list: 1 entries
seq 5 permit 10.1.0.0/16 le 24

R2#sh ip route eigrp
10.0.0.0/24 is subnetted, 11 subnets
D EX    10.1.10.0 [170/3097600] via 192.168.100.1, 00:05:37, Serial0/0
D EX    10.1.9.0 [170/3097600] via 192.168.100.1, 00:05:37, Serial0/0
D EX    10.1.8.0 [170/3097600] via 192.168.100.1, 00:05:37, Serial0/0
D EX    10.1.7.0 [170/3097600] via 192.168.100.1, 00:05:37, Serial0/0
R2#

 

This entry was posted in Route and tagged , , . Bookmark the permalink.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s