OSPF: NBMA, Point-to-Point, Point-to-Multipoint networks

This overall network diagram has 3 network types:

1. NBMA (default OSPF network type for cisco routers)

2. Point-to-point

3. Point to multipoint and point-to-point hybrid.

DR and BDR are only necessary in multi-access network, this is because multi-access network connects to many routers and hence each ospf speaking router will generate huge LSA traffic. Hence to solve this issue the DR scheme is created.

The role of the DR is to send LSA update to every ospf speaking routers, and those DRother routers (neither DR nor BDR) will send LSA update to the DR, LSA hello is still sent by all ospf routers for keepalive purpose. Also DRother routers will only form adjacency to DR and BDR. BDR is the backup of DR.

In point-to-point and point-to-multipoint networks, no DR is required hence BDR is also not necessary. Because point to point network has a pair of routers, hence ospf speaking routers formed adjacency with each other via unicast.

The default hello interval for broadcast network is 10s and 30s for non-broadcast network. This is important because routers will not form adjacency with each other if hello interval does not match.

Area 0 network is a default non-broadcast multi-access (NBMA) network, in this network ospf adjacency has to be formed manually using the neighbor command.

The configuration of R1:

interface Loopback0
ip address 1.1.1.1 255.255.255.0

interface Serial0/0
no ip address
encapsulation frame-relay
!
interface Serial0/0.1 multipoint
ip address 10.12.3.1 255.255.255.0
ip ospf priority 200
frame-relay map ip 10.12.3.2 102 broadcast
frame-relay map ip 10.12.3.3 103 broadcast

router ospf 1
router-id 1.1.1.1
log-adjacency-changes
network 1.1.1.1 0.0.0.0 area 0
network 10.12.3.1 0.0.0.0 area 0
neighbor 10.12.3.3
neighbor 10.12.3.2

In MA network a DR is needed. Since R1 is the hub with full connectivity with R2 and R3 R1 should be elected as DR, however because the router-id of R1 is the lowest among R2 and R3, R3 will probably be DR and R2 be a BDR if there is no user intervention. R2 and R3 are spoke routers, they do not have full connectivity with each other. If R3 needs to get to R2, R3 will have to pass through R1 first, R2 has the same situation too.

Hence to prevent R2 and R3 from being DR and BDR ip ospf priority 0 command is used. The highest priority value wins the DR, the next highest will be the BDR, 0 indicates that router can neither be elected as DR nor BDR.

Take note that DR and BDR are actually ospf speaking router’s interfaces’ properties. Hence ip ospf priority command is executed per router interface basis.

The configuration of R2:

interface Loopback0
ip address 2.2.2.2 255.255.255.0
!

interface Serial0/0
no ip address
encapsulation frame-relay
!
interface Serial0/0.1 multipoint
ip address 10.12.3.2 255.255.255.0
ip ospf priority 0
frame-relay map ip 10.12.3.1 201 broadcast
frame-relay map ip 10.12.3.3 201 broadcast
!

interface Serial0/1
no ip address
encapsulation frame-relay
!
interface Serial0/1.1 point-to-point
ip address 10.24.0.2 255.255.255.0
frame-relay interface-dlci 204
!
router ospf 1
router-id 2.2.2.2
log-adjacency-changes
network 2.2.2.2 0.0.0.0 area 0
network 10.12.3.2 0.0.0.0 area 0
network 10.24.0.2 0.0.0.0 area 24
network 10.24.0.4 0.0.0.0 area 24

Configuration of R3:

interface Loopback0
ip address 3.3.3.3 255.255.255.0
!

interface Serial0/0
no ip address
encapsulation frame-relay
!
interface Serial0/0.1 multipoint
ip address 10.12.3.3 255.255.255.0
ip ospf priority 0
frame-relay map ip 10.12.3.1 301 broadcast
frame-relay map ip 10.12.3.2 301 broadcast
!interface Serial0/1
no ip address
encapsulation frame-relay
!
interface Serial0/1.1 multipoint
ip address 10.35.6.3 255.255.255.0
ip ospf network point-to-multipoint
ip ospf hello-interval 10
frame-relay map ip 10.35.6.5 305 broadcast
frame-relay map ip 10.35.6.6 306 broadcast

router ospf 1
router-id 3.3.3.3
log-adjacency-changes
network 3.3.3.3 0.0.0.0 area 0
network 10.12.3.3 0.0.0.0 area 0
network 10.35.6.3 0.0.0.0 area 356

Area 24 is the point-to-point network, because only a pair of routers is connected to each other, adjacency will be formed if both routers agreed on the hello packet parameters.

Configuration of R2 is above, so here will list the configuration of R4:

interface Loopback0
ip address 4.4.4.4 255.255.255.255
!

interface Serial0/0
no ip address
encapsulation frame-relay
clock rate 2000000
!
interface Serial0/0.1 point-to-point
ip address 10.24.0.4 255.255.255.0
frame-relay interface-dlci 402

router ospf 1
router-id 4.4.4.4
log-adjacency-changes
network 4.4.4.4 0.0.0.0 area 24
network 10.24.0.4 0.0.0.0 area 24

Area 356 presents a hybrid network of point-to-point as well as point-to-multipoint. R3 is configured as a multipoint frame relay, while R5 and R6 are point-to-point frame relay.

R3’s default non-broadcast network type was changed to point-to-multipoint type by using the router interface command: ip ospf network point-to-multipoint

R5 and R6 are point-to-point frame relays, hence their network type is point-to-point network. You can verify the network type by using show ip ospf interface

Configuration of R3 is above. This section will show R5 and R6 configurations.

Configuration of R5:

interface Loopback0
ip address 5.5.5.5 255.255.255.255
!

interface Serial0/0
no ip address
encapsulation frame-relay
!
interface Serial0/0.1 point-to-point
ip address 10.35.6.5 255.255.255.0
ip ospf network point-to-point
frame-relay interface-dlci 503

router ospf 1
router-id 5.5.5.5
log-adjacency-changes
network 5.5.5.5 0.0.0.0 area 356
network 10.35.6.5 0.0.0.0 area 356
!

Configuration of R6:

interface Loopback0
ip address 6.6.6.6 255.255.255.255

interface Serial0/0
no ip address
encapsulation frame-relay
!
interface Serial0/0.1 point-to-point
ip address 10.35.6.6 255.255.255.0
frame-relay interface-dlci 603
!

router ospf 1
router-id 6.6.6.6
log-adjacency-changes
network 6.6.6.6 0.0.0.0 area 356
network 10.35.6.6 0.0.0.0 area 356
!

Advertisements
This entry was posted in OSPF and tagged . Bookmark the permalink.

5 Responses to OSPF: NBMA, Point-to-Point, Point-to-Multipoint networks

  1. Joseph says:

    Must be in different subnets the point-to-point sub interfaces in Routers R5 & R6 ?

  2. rakesh says:

    this is old post for anyone reading this blog in area 0 as the network is non broadcast and we are configuring static neighbor it is not necessary to put broadcast in frame relay map ip x.x.x.x broadcast

    • Andrew says:

      Rakesh, I removed the broadcast option in my lab and the neighbor came down. (“frame-relay map ip x.x.x.x yyy” instead of “frame-relay map ip x.x.x.x yyy broadcast”) I think the broadcast option is taking the broadcast messages and making them unicast so they will work on the non broadcast network.

    • Andrew says:

      Rakesh, My lab was not using the neighbor command. It was using a broadcast network type on R1 along with the broadcast option in the frame map command. You are right, broadcast isn’t needed with the above setup.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s