OSPF: Multi-Area configuration and simple redistribution

Scenario: All routers’ IP addresses have been configured, our client wants data to route to one another but does not have the know-how, we are engaged in configuring routing among routers. The above network diagram shows part of the overall network, you are tasked to use only OSPF to complete the task. Refer to requirements as discussed during the meeting between our consultant and our client.

Requirements:

1. 2651-5 should be the autonomous system border router (ASBR) to redistribute static routes into the OSPF network.

2. As there’s only one path to the static route, the static route metric should not be incremented as they pass through the network, they should have initial OSPF cost 200.

3. router-id should be used for router’s id, all OSPF enabled routers should be able to ping router-id

Tentatively these are the basic requirements, there may be ad hoc requirements to this set up.

2651-5(config)#do sh ip route

C    192.168.30.0/24 is directly connected, Loopback3
C    192.168.10.0/24 is directly connected, Loopback1
172.20.0.0/24 is subnetted, 1 subnets
C       172.20.0.0 is directly connected, FastEthernet0/0
C    192.168.20.0/24 is directly connected, Loopback2

Originally for the lab set up these are loopback interfaces, however to simulate the static route I can do a static route via null 0, remember to remove all loopback interfaces:

2651-5(config)#ip route 192.168.10.0 255.255.255.0 null 0
2651-5(config)#ip route 192.168.20.0 255.255.255.0 null 0
2651-5(config)#ip route 192.168.30.0 255.255.255.0 null 0

2651-5(config)#router ospf 1

2651-5(config-router)#network 172.20.0.5 0.0.0.0 area 0

2651-5(config-router)#router-id 5.5.5.5

Router’s ID influences the designated router election, router-id command will be the first priority in choosing the router’s name, follow by loopback interfaces, follow by physical interface’s highest ip address.

2651-5(config-router)#redistribute static subnets metric 200 metric-type 2

External routes (static routes) need to be introduced into a ospf network I need to redistribute the static routes, the subnet keyword tells the specific subnet mask that the static networks are using, if no subnet key word is used OSPF will assume the network 192.168.0.0 to be subnet mask of 255.255.255.0 (classful network). From the objective the cost should be 200, hence metric cost is set to 200, metric-type has two, one is E1 which will increment on each hop, the other is E2 which will be constant on every hop. The default metric-type is E2. For this objective no metric incrementation is required.

2651-2#sh ip int brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            172.20.0.2      YES manual up                    up
Serial0/0                  172.20.2.2      YES manual up                    up

2651-2(config)#router ospf 1
2651-2(config-router)#router-id 2.2.2.2
2651-2(config-router)#network 172.20.0.2 0.0.0.0 area 0

*Sep 19 12:39:11.701: %OSPF-5-ADJCHG: Process 1, Nbr 5.5.5.5 on FastEthernet0/0 from LOADING to FULL, Loading Done

To verify OSPF neighbour relationship:

2651-2(config-router)#do sh ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
5.5.5.5           1   FULL/DR 00:00:34    172.20.0.5      FastEthernet0/0

2651-5 is the designated router…

2651-2(config-router)#network 172.20.2.2 0.0.0.0 area 2

From the network diagram 2651-2 serial 0/0 interface belongs to area 2 network.

Verify the routing table from 2651-5

2651-5(config)#do sh ip route

S    192.168.30.0/24 is directly connected, Null0
S    192.168.10.0/24 is directly connected, Null0
172.20.0.0/24 is subnetted, 2 subnets
C       172.20.0.0 is directly connected, FastEthernet0/0
O IA    172.20.2.0 [110/65] via 172.20.0.2, 00:02:03, FastEthernet0/0
S    192.168.20.0/24 is directly connected, Null0

The line in bold is the inter-area route. Route between Area 0 and Area 2.

Verify the routing table from 2651-2

2651-2(config-router)#do sh ip route

O E2 192.168.30.0/24 [110/200] via 172.20.0.5, 00:02:12, FastEthernet0/0
O E2 192.168.10.0/24 [110/200] via 172.20.0.5, 00:02:16, FastEthernet0/0

172.20.0.0/24 is subnetted, 2 subnets
C       172.20.0.0 is directly connected, FastEthernet0/0
C       172.20.2.0 is directly connected, Serial0/0
O E2 192.168.20.0/24 [110/200] via 172.20.0.5, 00:02:15, FastEthernet0/0

The lines in bold are external routes redistributed from 2651-5’s fa0/0 interface. E2 is the default metric-type which is non-incremental on every hop.

Notice from the lines in bold there is a parenthesis [110/200], the left is the default administrative distance of OSPF, the right value is the metric I specified.

2651-4(config)#do sh ip int brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            172.20.0.4      YES manual up                    up
Serial0/0                  172.20.1.2      YES NVRAM  up                    up

2651-4(config)#router ospf 1
2651-4(config-router)#router-id 4.4.4.4
2651-4(config-router)#network 172.20.0.4 0.0.0.0 area 0
*Sep 19 12:40:06.201: %OSPF-5-ADJCHG: Process 1, Nbr 2.2.2.2 on FastEthernet0/0 from LOADING to FULL, Loading Done
*Sep 19 12:40:06.201: %OSPF-5-ADJCHG: Process 1, Nbr 5.5.5.5 on FastEthernet0/0 from LOADING to FULL, Loading Done

2651-4(config-router)#network 172.20.1.2 0.0.0.0 area 1

Verify 2651-4

2651-4(config-router)#do sh ip route

O E2 192.168.30.0/24 [110/200] via 172.20.0.5, 00:00:41, FastEthernet0/0
O E2 192.168.10.0/24 [110/200] via 172.20.0.5, 00:00:41, FastEthernet0/0

172.20.0.0/24 is subnetted, 3 subnets
C       172.20.0.0 is directly connected, FastEthernet0/0
C       172.20.1.0 is directly connected, Serial0/0
O IA    172.20.2.0 [110/65] via 172.20.0.2, 00:00:41, FastEthernet0/0
O E2 192.168.20.0/24 [110/200] via 172.20.0.5, 00:00:41, FastEthernet0/0

2651-3#sh ip int brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            unassigned      YES NVRAM  administratively down down
Serial0/0                  172.20.1.1      YES NVRAM  up                    up
FastEthernet0/1            unassigned      YES NVRAM  administratively down down
Serial0/1                  unassigned      YES NVRAM  administratively down down
Loopback1                  10.1.1.1        YES manual up                    up
Loopback2                  10.1.2.1        YES manual up                    up
Loopback3                  10.1.3.1        YES manual up                    up
Loopback4                  10.1.4.1        YES manual up                    up

2651-3#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
2651-3(config)#router ospf 1
2651-3(config-router)#router-id 3.3.3.3
2651-3(config-router)#network 172.20.1.1 0.0.0.0 area 1
*Sep 19 12:50:20.128: %OSPF-5-ADJCHG: Process 1, Nbr 4.4.4.4 on Serial0/0 from LOADING to FULL, Loading Done
2651-3(config-router)#network 10.1.1.0 0.0.0.255 area 1
2651-3(config-router)#network 10.1.2.0 0.0.0.255 area 1
2651-3(config-router)#network 10.1.3.0 0.0.0.255 area 1
2651-3(config-router)#network 10.1.4.0 0.0.0.255 area 1
2651-3(config-router)#

2651-3 is a router fully in Area 1

Verify 2651-3 routing table.

2651-3(config-router)#do sh ip route

O E2 192.168.30.0/24 [110/200] via 172.20.1.2, 00:01:12, Serial0/0
O E2 192.168.10.0/24 [110/200] via 172.20.1.2, 00:01:12, Serial0/0
172.20.0.0/24 is subnetted, 3 subnets
O IA    172.20.0.0 [110/65] via 172.20.1.2, 00:01:12, Serial0/0

C       172.20.1.0 is directly connected, Serial0/0
O IA    172.20.2.0 [110/129] via 172.20.1.2, 00:01:12, Serial0/0
O E2 192.168.20.0/24 [110/200] via 172.20.1.2, 00:01:12, Serial0/0

10.0.0.0/24 is subnetted, 4 subnets
C       10.1.3.0 is directly connected, Loopback3
C       10.1.2.0 is directly connected, Loopback2
C       10.1.1.0 is directly connected, Loopback1
C       10.1.4.0 is directly connected, Loopback4

2651-1#sh ip int brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            unassigned      YES unset  administratively down down
Serial0/0                  172.20.2.1      YES manual up                    up
FastEthernet0/1            unassigned      YES unset  administratively down down
Serial0/1                  unassigned      YES unset  administratively down down
Serial0/2                  unassigned      YES unset  administratively down down
Serial0/3                  unassigned      YES unset  administratively down down
Loopback1                  10.2.1.1        YES manual up                    up
Loopback2                  10.2.2.1        YES manual up                    up
Loopback3                  10.2.3.1        YES manual up                    up
Loopback4                  10.2.4.1        YES manual up                    up

2651-1 is fully in Area 2.

2651-1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
2651-1(config)#router ospf 1
2651-1(config-router)#router-id 1.1.1.1
2651-1(config-router)#network 172.20.2.1 0.0.0.0 area 2
2651-1(config-router)#
*Mar  3 09:23:31.050: %OSPF-5-ADJCHG: Process 1, Nbr 2.2.2.2 on Serial0/0 from LOADING to FULL, Loading Done
2651-1(config-router)#network 10.2.0.0 0.0.255.255 area 2

2651-1(config-router)#do sh ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route

Gateway of last resort is not set

O E2 192.168.30.0/24 [110/200] via 172.20.2.2, 00:00:37, Serial0/0
O E2 192.168.10.0/24 [110/200] via 172.20.2.2, 00:00:37, Serial0/0
172.20.0.0/24 is subnetted, 3 subnets
O IA    172.20.0.0 [110/65] via 172.20.2.2, 00:00:37, Serial0/0
O IA    172.20.1.0 [110/129] via 172.20.2.2, 00:00:37, Serial0/0

C       172.20.2.0 is directly connected, Serial0/0
O E2 192.168.20.0/24 [110/200] via 172.20.2.2, 00:00:37, Serial0/0
10.0.0.0/8 is variably subnetted, 8 subnets, 2 masks
O IA    10.1.2.1/32 [110/130] via 172.20.2.2, 00:00:38, Serial0/0
C       10.2.1.0/24 is directly connected, Loopback1
O IA    10.1.3.1/32 [110/130] via 172.20.2.2, 00:00:38, Serial0/0
C       10.2.2.0/24 is directly connected, Loopback2
C       10.2.3.0/24 is directly connected, Loopback3
O IA    10.1.1.1/32 [110/130] via 172.20.2.2, 00:00:40, Serial0/0
C       10.2.4.0/24 is directly connected, Loopback4
O IA    10.1.4.1/32 [110/130] via 172.20.2.2, 00:00:40, Serial0/0


Advertisements
This entry was posted in OSPF, Route and tagged . Bookmark the permalink.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google+ photo

You are commenting using your Google+ account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s