EIGRP (NMBA-Multipoint frame-relay): Configure routing part 2

1. Use EIGRP autonomous system number 100 to form route among 3 branch offices.

New networks added to West office:

West#sh ip route

Gateway of last resort is not set

172.30.0.0/29 is subnetted, 1 subnets
C       172.30.10.0 is directly connected, Serial0/0.1
10.0.0.0/24 is subnetted, 4 subnets
C       10.3.1.0 is directly connected, Loopback1
C       10.3.3.0 is directly connected, Loopback3
C       10.3.2.0 is directly connected, Loopback2
C       10.3.4.0 is directly connected, Loopback4

New networks added to East office:

East#sh ip route

Gateway of last resort is not set

172.30.0.0/29 is subnetted, 1 subnets
C       172.30.10.0 is directly connected, Serial0/0.1
10.0.0.0/24 is subnetted, 5 subnets
C       10.2.1.0 is directly connected, Loopback1
C       10.2.2.0 is directly connected, Loopback2
C       10.2.3.0 is directly connected, Loopback3
C       10.2.4.0 is directly connected, Loopback4
C       10.2.5.0 is directly connected, Loopback5

New networks added to HQ office:

HQ#sh ip route

Gateway of last resort is not set

172.30.0.0/29 is subnetted, 1 subnets
C       172.30.10.0 is directly connected, Serial0/0.1
10.0.0.0/24 is subnetted, 3 subnets
C       10.1.3.0 is directly connected, Loopback3
C       10.1.2.0 is directly connected, Loopback2
C       10.1.1.0 is directly connected, Loopback1

HQ#configure terminal
HQ(config)#router eigrp 100
HQ(config-router)#no auto-summary
HQ(config-router)#network 10.1.0.0 0.0.255.255
HQ(config-router)#network 172.30.10.0 0.0.0.255

East#conf t
East(config)#router eigrp 100
East(config-router)#network 10.2.0.0 0.0.255.255
East(config-router)#network 172.30.10.0 0.0.0.255
*Mar  1 02:33:58.950: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 172.30.10.1 (Serial0/0.1) is up: new adjacency
East(config-router)#no auto
*Mar  1 02:34:01.386: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 172.30.10.1 (Serial0/0.1) is resync: summary configured
East(config-router)#

West(config)#router eigrp 100
West(config-router)#network 10.3.0.0 0.0.255.255
West(config-router)#network 172.30.10.0 0.0.0.255
*Mar  1 15:51:35.014: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 172.30.10.1 (Serial0/0.1) is up: new adjacency
West(config-router)#no auto-summary
*Mar  1 15:51:37.202: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 172.30.10.1 (Serial0/0.1) is resync: summary configured
West(config-router)#

West#sh ip route

Gateway of last resort is not set

172.30.0.0/29 is subnetted, 1 subnets
C       172.30.10.0 is directly connected, Serial0/0.1
10.0.0.0/24 is subnetted, 7 subnets
C       10.3.1.0 is directly connected, Loopback1
D       10.1.3.0 [90/2297856] via 172.30.10.1, 00:01:10, Serial0/0.1
D       10.1.2.0 [90/2297856] via 172.30.10.1, 00:01:10, Serial0/0.1

C       10.3.3.0 is directly connected, Loopback3
D       10.1.1.0 [90/2297856] via 172.30.10.1, 00:01:10, Serial0/0.1
C       10.3.2.0 is directly connected, Loopback2
C       10.3.4.0 is directly connected, Loopback4

Only 10.1.x.x routes are known, 10.2.x.x routes are unknown. HQ office router did not send route update back to the interface where it learned from, this is the split horizon rule.

And also because multipoint frame relay is created under sub interfaces split horizon is turned on by default.

East#sh ip

Gateway of last resort is not set

172.30.0.0/29 is subnetted, 1 subnets
C       172.30.10.0 is directly connected, Serial0/0.1
10.0.0.0/24 is subnetted, 8 subnets
D       10.1.3.0 [90/2297856] via 172.30.10.1, 00:08:09, Serial0/0.1
C       10.2.1.0 is directly connected, Loopback1
D       10.1.2.0 [90/2297856] via 172.30.10.1, 00:08:09, Serial0/0.1
C       10.2.2.0 is directly connected, Loopback2
D       10.1.1.0 [90/2297856] via 172.30.10.1, 00:08:09, Serial0/0.1
C       10.2.3.0 is directly connected, Loopback3
C       10.2.4.0 is directly connected, Loopback4
C       10.2.5.0 is directly connected, Loopback5

Same as West router, East office router did not get the route to 10.3.x.x, HQ office router did not send the route of West router to East router, because route update will not be sent back to the interface were it learned the route from. This is split horizon rule, and it became a problem for this multipoint frame relay set up.

Workaround is to turn off split horizon at HQ router’s interfaces.

HQ(config)#int se0/0.1
HQ(config-subif)#no ip split-horizon eigrp 100
HQ(config-subif)#
*Mar  2 11:30:36.613: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 172.30.10.3 (Serial0/0.1) is resync: split horizon changed
*Mar  2 11:30:36.617: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 172.30.10.2 (Serial0/0.1) is resync: split horizon changed
HQ(config-subif)#

West#sh ip route
Gateway of last resort is not set

172.30.0.0/29 is subnetted, 1 subnets
C       172.30.10.0 is directly connected, Serial0/0.1
10.0.0.0/24 is subnetted, 12 subnets
C       10.3.1.0 is directly connected, Loopback1
D       10.1.3.0 [90/2297856] via 172.30.10.1, 00:08:15, Serial0/0.1
D       10.2.1.0 [90/2809856] via 172.30.10.1, 00:00:48, Serial0/0.1
D       10.1.2.0 [90/2297856] via 172.30.10.1, 00:08:15, Serial0/0.1
C       10.3.3.0 is directly connected, Loopback3
D       10.2.2.0 [90/2809856] via 172.30.10.1, 00:00:48, Serial0/0.1
D       10.1.1.0 [90/2297856] via 172.30.10.1, 00:08:16, Serial0/0.1
C       10.3.2.0 is directly connected, Loopback2
D       10.2.3.0 [90/2809856] via 172.30.10.1, 00:00:49, Serial0/0.1
D       10.2.4.0 [90/2809856] via 172.30.10.1, 00:00:49, Serial0/0.1

C       10.3.4.0 is directly connected, Loopback4
D       10.2.5.0 [90/2809856] via 172.30.10.1, 00:00:51, Serial0/0.1

West router gets the route to East.

East#sh ip route
Gateway of last resort is not set

172.30.0.0/29 is subnetted, 1 subnets
C       172.30.10.0 is directly connected, Serial0/0.1
10.0.0.0/24 is subnetted, 12 subnets
D       10.3.1.0 [90/2809856] via 172.30.10.1, 00:01:49, Serial0/0.1
D       10.1.3.0 [90/2297856] via 172.30.10.1, 00:13:34, Serial0/0.1
C       10.2.1.0 is directly connected, Loopback1
D       10.1.2.0 [90/2297856] via 172.30.10.1, 00:13:34, Serial0/0.1
D       10.3.3.0 [90/2809856] via 172.30.10.1, 00:01:49, Serial0/0.1
C       10.2.2.0 is directly connected, Loopback2
D       10.1.1.0 [90/2297856] via 172.30.10.1, 00:13:35, Serial0/0.1
D       10.3.2.0 [90/2809856] via 172.30.10.1, 00:01:50, Serial0/0.1
C       10.2.3.0 is directly connected, Loopback3
C       10.2.4.0 is directly connected, Loopback4
D       10.3.4.0 [90/2809856] via 172.30.10.1, 00:01:52, Serial0/0.1
C       10.2.5.0 is directly connected, Loopback5

East knows the existence of a route to East router from HQ.

2. All routers should reach one another.

West#ping 10.3.2.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.3.2.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
West#

HQ#sh ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route

Gateway of last resort is not set

172.30.0.0/29 is subnetted, 1 subnets
C       172.30.10.0 is directly connected, Serial0/0.1
10.0.0.0/24 is subnetted, 12 subnets
D       10.3.1.0 [90/2297856] via 172.30.10.3, 00:12:55, Serial0/0.1
C       10.1.3.0 is directly connected, Loopback3
D       10.2.1.0 [90/2297856] via 172.30.10.2, 00:17:13, Serial0/0.1
C       10.1.2.0 is directly connected, Loopback2
D       10.3.3.0 [90/2297856] via 172.30.10.3, 00:12:55, Serial0/0.1
D       10.2.2.0 [90/2297856] via 172.30.10.2, 00:17:13, Serial0/0.1
C       10.1.1.0 is directly connected, Loopback1
D       10.3.2.0 [90/2297856] via 172.30.10.3, 00:12:57, Serial0/0.1
D       10.2.3.0 [90/2297856] via 172.30.10.2, 00:17:15, Serial0/0.1
D       10.2.4.0 [90/2297856] via 172.30.10.2, 00:17:15, Serial0/0.1
D       10.3.4.0 [90/2297856] via 172.30.10.3, 00:12:58, Serial0/0.1
D       10.2.5.0 [90/2297856] via 172.30.10.2, 00:17:16, Serial0/0.1
HQ#ping 10.3.2.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.3.2.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/6/8 ms
HQ#

East#ping 10.1.2.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.2.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/8/8 ms
East#

West#ping 10.1.3.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.3.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/6/8 ms
West#ping 10.2.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.2.1.1, timeout is 2 seconds:
…..
Success rate is 0 percent (0/5)
West#

East and West can only reach HQ offices with ping, but East and West cannot reach each other using ping. Hmm..

Advertisements
This entry was posted in EIGRP, Route and tagged . Bookmark the permalink.

One Response to EIGRP (NMBA-Multipoint frame-relay): Configure routing part 2

  1. shehreyar khan says:

    create PVC Between West and East it will build neighbor relationship between West and East so you will be able to ping them

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google+ photo

You are commenting using your Google+ account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

w

Connecting to %s