EIGRP (NBMA: Multipoint): Neighbor command and Split horizon problem in NBMA

EIGRP is using multicast address 224.0.0.10 to automatically form neighborship among neighbours, however this nature can be changed by using the keyword neighbor. You will need to specify the address of your neighbor and instead of multicast. unicast is used to form neighborship. EIGRP will stop sending multicast packet on that surface.

To manually add neighborship to your EIGRP router:

HQ(config)#int lo1
HQ(config-if)#ip address 192.168.1.1 255.255.255.0

West(config)#int lo1
West(config-if)#ip address 192.168.3.1 255.255.255.0

East(config)#int lo1
East(config-if)#ip address 192.168.2.1 255.255.255.0

HQ(config-router)#neighbor 172.30.10.2 se0/0.1

HQ(config-router)#neighbor 192.168.1.1 lo1

HQ(config-router)#network 172.30.10.0 0.0.0.7
HQ(config-router)#network 192.168.1.0 0.0.0.255

HQ(config-router)#no auto

West(config-router)#neighbor 192.168.3.1 lo1

West(config-router)#neighbor 172.30.10.1 se0/0.1
West(config-router)#no auto

West(config-router)#network 192.168.3.0 0.0.0.255
West(config-router)#network 172.30.10.0 0.0.0.7
West(config-router)#
*Mar  1 14:53:29.068: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 172.30.10.1 (Serial0/0.1) is up: new adjacency

East(config-router)#neighbor 172.30.10.1 se0/0.1
East(config-router)#neighbor 192.168.2.1 loopback 1

East(config-router)#no auto
East(config-router)#network 192.168.2.0 0.0.0.255
East(config-router)#network 172.30.10.0 0.0.0.7

East#sh ip route eigrp 100
D    192.168.1.0/24 [90/2297856] via 172.30.10.1, 00:06:34, Serial0/0.1
East#

Split horizon problem, only one route is known

East#sh ip eigrp 100 neighbors
IP-EIGRP neighbors for process 100
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
(sec)         (ms)       Cnt Num
0   172.30.10.1             Se0/0.1          154 00:14:14    5   200  0  11

HQ#sh ip eigrp 100 neighbors
IP-EIGRP neighbors for process 100
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
(sec)         (ms)       Cnt Num
1   172.30.10.3             Se0/0.1          157 00:04:00    5   200  0  3
0   172.30.10.2             Se0/0.1          158 00:15:03    4   200  0  8

HQ#sh ip route eigrp 100
D    192.168.2.0/24 [90/2297856] via 172.30.10.2, 00:02:43, Serial0/0.1
D    192.168.3.0/24 [90/2297856] via 172.30.10.3, 00:04:43, Serial0/0.1

HQ learned the route from East and West but did not tell East about West’s route, and West about East’s route.

West#sh ip eigrp 100 neighbors
IP-EIGRP neighbors for process 100
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
(sec)         (ms)       Cnt Num
0   172.30.10.1             Se0/0.1          129 00:05:26   10   200  0  11

West#sh ip route eigrp 100
D    192.168.1.0/24 [90/2297856] via 172.30.10.1, 00:05:54, Serial0/0.1

Split horizon problem, only one route is known.

Split horizon (thanks Jeremy Cioara): I will not tell somebody something that they told me

HQ(config)#interface se0/0.1
HQ(config-subif)#no ip split-horizon eigrp 100

East#sh ip route eigrp 100
D    192.168.1.0/24 [90/2297856] via 172.30.10.1, 00:20:54, Serial0/0.1
D    192.168.3.0/24 [90/2809856] via 172.30.10.1, 00:00:58, Serial0/0.1

West#sh ip route eigrp 100
D    192.168.1.0/24 [90/2297856] via 172.30.10.1, 00:17:50, Serial0/0.1
D    192.168.2.0/24 [90/2809856] via 172.30.10.1, 00:01:41, Serial0/0.1

Disable split horizon from HQ’s se0/0.1 interface, HQ tells East about route to West, and West about route to East.

Note: Split horizon is disabled by default if you configure multipoint frame-relay on the physical interface. If you configure the multipoint frame-relay on the sub interfaces like the one I did here then split horizon is turned on by default.

Advertisements
This entry was posted in EIGRP, Route and tagged , , . Bookmark the permalink.

2 Responses to EIGRP (NBMA: Multipoint): Neighbor command and Split horizon problem in NBMA

  1. Joel Asaro says:

    I also thought split horizon was off by default and that is in fact what the Cisco Press text I am studying from says, but turns out it is not the case for EIGRP. See here:
    http://www.cisco.com/en/US/tech/tk713/tk237/technologies_q_and_a_item09186a008009457a.shtml#routing

    • ciscolok says:

      Hi Joel,

      Thanks for the link. Apparently from the FAQ EIGRP has to be turned off explicitly, however did you try configuring multipoint frame-relay on physical interface instead of sub interface?

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s