EIGRP: Configuration and verification Part1

Scenario: You are tasked to configure EIGRP routing among various departments.

Loopback1 of R1 is Engineering, loopback2 of R2 is Marketing, loopback3 of R3 is Sales. All physical connections have already been installed as shown in this logical network diagram.

You do not need to configure anything on the switch. The switch has a localized vlan1 only.

Task1: Although the physical cables are connected, no ip addressing is in place. Your first task is to configure all ip addresses on each interfaces as specify by the network diagram.

Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#hostname R1

R1(config-if)#clock rate 512000
*Mar  2 09:48:39.525: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changed state to up
R1(config-if)#description This is a DCE to R2

R1(config-if)#ip address 10.0.1.1 255.255.255.0
R1(config-if)#no shut
R1(config-if)#exit

Router(config)#hostname R2
R2(config)#int se0/0
R2(config-if)#ip address 10.0.1.2 255.255.255.0
R2(config-if)#no shut
R2(config-if)#exit

R1(config)#int fa0/0
R1(config-if)#ip address 10.0.0.1 255.255.255.0
R1(config-if)#no shut
R1(config-if)#exit

R1(config)#int lo1
*Mar  2 10:20:17.929: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback1, changed state to up
R1(config-if)#ip address 10.1.1.1 255.255.255.0

R1(config-if)#description Engineering Network

R1(config-if)#exit

R2(config)#int fa0/0
R2(config-if)#ip address 10.0.0.2 255.255.255.0
R2(config-if)#no shut

R2(config-if)#int lo2
*Mar  2 10:21:42.874: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback2, changed state to up
R2(config-if)#ip address 10.1.2.1 255.255.255.0

R2(config-if)#description Marketing Network

R2(config-if)#exit

Router>en
Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#hostname R3
R3(config)#int fa0/0
R3(config-if)#ip address 10.0.0.3 255.255.255.0
R3(config-if)#no shut

R3(config-if)#int lo3

R3(config-if)#ip address 10.1.3.1 255.255.255.0

R3(config-if)#description Sales Network

Task 2: Configuring EIGRP across vlan 1 using ASN 100

Before configuring dynamic routing protocol it is good to verify if the connections are up.

R1#show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            10.0.0.1        YES manual up                    up
Serial0/0                  10.0.1.1        YES manual up                    up

FastEthernet0/1            unassigned      YES unset  administratively down down
Serial0/1                  unassigned      YES unset  administratively down down
Serial0/2                  unassigned      YES unset  administratively down down
Serial0/3                  unassigned      YES unset  administratively down down
Loopback1                  10.1.1.1        YES manual up                    up

Note: This is a mock live network you should not turn on any debug in a live network

Turn on debug to monitor EIGRP activities.

R1#debug eigrp packets
EIGRP Packets debugging is on
(UPDATE, REQUEST, QUERY, REPLY, HELLO, IPXSAP, PROBE, ACK, STUB, SIAQUERY, SIAREPLY)

This command turns on all EIGRP packets, you can specify the packet type you want to see.

R1(config)#router eigrp 100
R1(config-router)#no auto-summary
R1(config-router)#passive-interface default
R1(config-router)#no passive-interface fa0/0
R1(config-router)#network 10.0.0.0 0.0.0.255

As soon as network is defined EIGRP will start sending hellos. Loopback interface is not a real physical interface, hence it will not generate any hello packets.

*Mar  2 10:45:03.540: EIGRP: Sending HELLO on FastEthernet0/0
*Mar  2 10:45:03.540:   AS 100, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0

R1(config-router)#
*Mar  2 10:45:07.819: EIGRP: Sending HELLO on FastEthernet0/0
*Mar  2 10:45:07.819:   AS 100, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
R1(config-router)#
*Mar  2 10:45:12.423: EIGRP: Sending HELLO on FastEthernet0/0
*Mar  2 10:45:12.423:   AS 100, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0

R1(config-router)#
*Mar  2 10:45:16.774: EIGRP: Sending HELLO on FastEthernet0/0
*Mar  2 10:45:16.774:   AS 100, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0

R2(config)#router eigrp 100
R2(config-router)#no auto-summary
R2(config-router)#passive-interface default
R2(config-router)#no passive-interface fa0/0
R2(config-router)#network 10.0.0.0 0.0.0.255

R1 and R2 exchange hello with each other and adjacency is formed.

*Mar  2 10:49:13.828: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 10.0.0.1 (FastEthernet0/0) is up: new adjacency

Verify EIGRP neighbourship.

R2#sh ip eigrp neighbors
IP-EIGRP neighbors for process 100
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
(sec)         (ms)       Cnt Num
0   10.0.0.1                Fa0/0             12 00:03:02 1279  5000  0  3

Default timer for hello packet is every 5secs, hold down timer is 15secs it is recommended that the hold time is not below 10s. If below 10s that means the neighbour might have a link problem.

To demonstrate this I shutdown interface fa0/0 of R1:

R1(config)#int fa0/0
R1(config-if)#shut
R1(config-if)#

R2#sh ip eigrp neighbors
IP-EIGRP neighbors for process 100
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
(sec)         (ms)       Cnt Num
0   10.0.0.1                Fa0/0              7 00:04:46 1279  5000  0  3
R2#sh ip eigrp neighbors
IP-EIGRP neighbors for process 100
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
(sec)         (ms)       Cnt Num
0   10.0.0.1                Fa0/0              5 00:04:48 1279  5000  0  3
R2#sh ip eigrp neighbors
IP-EIGRP neighbors for process 100
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
(sec)         (ms)       Cnt Num
0   10.0.0.1                Fa0/0              3 00:04:49 1279  5000  0  3
R2#sh ip eigrp neighbors
IP-EIGRP neighbors for process 100
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
(sec)         (ms)       Cnt Num
0   10.0.0.1                Fa0/0              2 00:04:51 1279  5000  0  3
R2#sh ip eigrp neighbors
IP-EIGRP neighbors for process 100
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
(sec)         (ms)       Cnt Num
0   10.0.0.1                Fa0/0              0 00:04:52 1279  5000  0  3
R2#sh ip eigrp neighbors
IP-EIGRP neighbors for process 100
R2#
*Mar  2 10:54:07.253: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 10.0.0.1 (FastEthernet0/0) is down: holding time expired

So if the hold down timer is less than 10s then there will be a possibility of a link problem of the neighbour.

*Mar  2 10:56:55.220: EIGRP: Sending HELLO on FastEthernet0/0
*Mar  2 10:56:55.220:   AS 100, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0

R2 keeps trying to find a neighbour.

When R1’s interface fa0/0 is up, adjacency is formed

Tserver#2
[Resuming connection 2 to 2651-2 … ]

*Md UPDATE on FastEthernet0/0 nbr 10.0.0.1
*Mar  2 10:57:06.844:   AS 100, Flags 0x8, Seq 6/6 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/1
*Mar  2 10:57:06.844: EIGRP: Enqueueing ACK on FastEthernet0/0 nbr 10.0.0.1

*Mar  2 10:57:06.844:   Ack seq 6 iidbQ un/rely 0/0 peerQ un/rely 1/0
*Mar  2 10:57:06.848: EIGRP: Sending ACK on FastEthernet0/0 nbr 10.0.0.1
*Mar  2 10:57:06.848:   AS 100, Flags 0x0, Seq 0/6 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 1/0
R2#
R2#
*Mar  2 10:57:09.203: EIGRP: Sending HELLO on FastEthernet0/0
*Mar  2 10:57:09.203:   AS 100, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
*Mar  2 10:57:09.396: EIGRP: Received HELLO on FastEthernet0/0 nbr 10.0.0.1
*Mar  2 10:57:09.396:   AS 100, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/0

R3#debug eigrp packets

R3#debug eigrp neighbors

Debug output of R3 after R3 starts sending hellos.

R3(config-router)#
*Mar  1 13:29:23.249: EIGRP: Sending HELLO on FastEthernet0/0
*Mar  1 13:29:23.249:   AS 100, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
*Mar  1 13:29:23.253: EIGRP: Received HELLO on FastEthernet0/0 nbr 10.0.0.1
*Mar  1 13:29:23.253:   AS 100, Flags 0x0, Seq 0/0 idbQ 0/0
*Mar  1 13:29:23.257: EIGRP: New peer 10.0.0.1 total=1 stub 0 template=0 idbstub=0 iidball=1
*Mar  1 13:29:23.257: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 10.0.0.1 (FastEthernet0/0) is up: new adjacency

R3 received R1’s hello first, and they became friends. R3 tells R1 that he is the only friend (peer) and he has no stub.
*Mar  1 13:29:23.257: EIGRP: Enqueueing UPDATE on FastEthernet0/0 nbr 10.0.0.1 iidbQ un/rely 0/1 peerQ un/rely 0/0
*Mar  1 13:29:23.257: EIGRP: Received HELLO on FastEthernet0/0 nbr 10.0.0.2
*Mar  1 13:29:23.257:   AS 100, Flags 0x0, Seq 0/0 idbQ 0/0
*Mar  1 13:29:23.257: EIGRP: New peer 10.0.0.2 total=2 stub 0 template=0 idbstub=0 iidball=2
*Mar  1 13:29:23.257: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 10.0.0.2 (FastEthernet0/0) is up: new adjacency
*Mar  1 13:29:23.257: EIGRP: Enqueueing UPD

A while later R3 received R2’s hello, and they too became friends. R3 told R2 that R2 and R1 are his friends (New peer 10.0.0.2 total=2) and he has no stub.

*Mar  1 13:29:23.261: EIGRP: Requeued unicast on FastEthernet0/0
*Mar  1 13:29:23.261: EIGRP: Requeued unicast on FastEthernet0/0
*Mar  1 13:29:23.265: EIGRP: Sending HELLO on FastEthernet0/0
*Mar  1 13:29:23.265:   AS 100, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
*Mar  1 13:29:23.265: EIGRP: Sending UPDATE on FastEthernet0/0 nbr 10.0.0.1
*Mar  1 13:29:23.265:   AS 100, Flags 0x1, Seq 1/0 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/1
*Mar  1 13:29:23.269: EIGRP: Forcing multicast xmit on FastEthernet0/0
*Mar  1 13:29:23.269: EIGRP: Sending UPDATE on FastEthernet0/0 nbr 10.0.0.2
*Mar  1 13:29:23.269:   AS 100, Flags 0x1, Seq 2/0 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/1
*Mar  1 13:29:23.269: EIGRP: Enqueueing UPDATE on FastEthernet0/0 iidbQ un/rely 0/1 serno 1-1
*Mar  1 13:29:23.273: EIGRP: Building Sequence TLV
*Mar  1 13:29:23.273: EIGRP: Enqueueing UPDATE on FastEthernet0/0 nbr 10.0.0.2 iidbQ un/rely 0/0 peerQ un/rely 0/1 serno 1-1
*Mar  1 13:29:23.273: EIGRP: Enqueueing UPDATE on FastEthernet0/0 nbr 10.0.0.1 iidbQ un/rely 0/0 peerQ un/rely 0/1 serno 1-1
*Mar  1 13:29:23.273: EIGRP: Sending HELLO with Sequence TLV on FastEthernet0/0, seq 3
*Mar  1 13:29:23.273: EIGRP: Sending HELLO on FastEthernet0/0

When EIGRP routers first became neighbours they began to exchange updates. If no changes occur the update will cease and normal hello keepalive message is exchanged among them. The above output actually went on for 3 rounds.

*Mar  1 13:29:32.031: EIGRP: Sending HELLO on FastEthernet0/0
*Mar  1 13:29:32.031:   AS 100, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
*Mar  1 13:29:32.432: EIGRP: Received HELLO on FastEthernet0/0 nbr 10.0.0.1
*Mar  1 13:29:32.432:   AS 100, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/0
*Mar  1 13:29:32.444: EIGRP: Received HELLO on FastEthernet0/0 nbr 10.0.0.2
*Mar  1 13:29:32.444:   AS 100, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/0

This is the typical state when there’s no further updates of the network. This is similar to human’s social habit, when you first meet new friends who have the same interest as you, both of you began to talk and exchange information pertaining your interest. After a while all of you will keep in contact with one another, if there’s something new pertaining to the interest all of you shared, you will start to exchange new updates again.

This is similar to EIGRP, after the initial updates were established no more update will be sent or received if the network is stable and no changes, the only activity happens is keepalive hello message exchange. If there’s changes, updates of the change will be exchanged.

Advertisements
This entry was posted in EIGRP, Route and tagged , , . Bookmark the permalink.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s