EIGRP Objective 1

EIGRP Objective 1

by Cyrus Lok on Sunday, September 5, 2010 at 5:43pm

Background: MTA stands for Megasource TechnoActive, a new startup system integrator that provide wide area network solutions, home office solution, enterprise infrastructure maintenance, process network solution, process network maintenance, network security services…etc

You are hired as a network engineer by MTA, recently MTA gets a new deal from XYZ corporation, MTA wants you to be involved in the project but unsure of your technical skill, you are tested on the below requirements which are part of the implementation in the project.

Objective:

1. MTA policy states that you must only use EIGRP with ASN 90.

2. MTA policy dictates that R2 and R3 must use specific wildcard masks.

3. EIGRP should be configured such a way that it does not operate like a classful routing.

4. BB1 has a directed connected interface 192.168.1.0/24, R2 and R3 must have default route point to this network, default route MUST not be done using a static route.

5. EIGRP routers should not form neighbourhoodship with non-EIGRP routers.

6. BB1 must summarise network from 172.16.10.0 – 50.0 for efficiency.

BB1 partial configuration:

interface Loopback0

ip address 172.16.10.1 255.255.255.0

!

interface Loopback1

ip address 172.16.20.1 255.255.255.0

!

interface Loopback2

ip address 172.16.30.1 255.255.255.0

!

interface Loopback3

ip address 172.16.40.1 255.255.255.0

!

interface Loopback4

ip address 172.16.50.1 255.255.255.0

!

interface Loopback5

ip address 192.168.1.254 255.255.255.0

!

interface FastEthernet0/0

description To R2

ip address 192.168.255.1 255.255.255.252

ip summary-address eigrp 90 172.16.0.0 255.255.192.0 5

speed 100

full-duplex

!

interface Serial0/0

no ip address

shutdown

!

interface FastEthernet0/1

description To R3

ip address 192.168.255.5 255.255.255.252

ip summary-address eigrp 90 172.16.0.0 255.255.192.0 5

speed 100

full-duplex

!

interface Serial0/1

no ip address

shutdown

!

router eigrp 90

passive-interface Loopback5

network 172.16.10.0 0.0.0.255

network 172.16.20.0 0.0.0.255

network 172.16.30.0 0.0.0.255

network 172.16.40.0 0.0.0.255

network 172.16.50.0 0.0.0.255

network 192.168.1.0

network 192.168.255.0 0.0.0.3

network 192.168.255.4 0.0.0.3

no auto-summary

!

ip default-network 192.168.1.0

R2 Partial configuration:

interface Loopback0

ip address 172.30.1.1 255.255.255.240

!

interface FastEthernet0/0

ip address 192.168.255.2 255.255.255.252

speed 100

full-duplex

!

interface Serial0/0

no ip address

shutdown

no fair-queue

!

interface FastEthernet0/1

ip address 10.1.10.1 255.255.255.0

speed 100

full-duplex

!

interface Serial0/1

no ip address

shutdown

!

router eigrp 90

passive-interface Loopback0

network 10.1.10.0 0.0.0.255

network 172.30.1.0 0.0.0.15

network 192.168.255.0 0.0.0.3

no auto-summary

!

ip default-network 192.168.1.0

R3 partial configuration:

interface FastEthernet0/0

ip address 10.1.20.1 255.255.255.0

speed 100

full-duplex

!

interface Serial0/0

no ip address

shutdown

no fair-queue

!

interface FastEthernet0/1

ip address 192.168.255.6 255.255.255.252

speed 100

full-duplex

!

interface Serial0/1

no ip address

shutdown

!

router eigrp 90

passive-interface FastEthernet0/0

network 10.1.20.0 0.0.0.255

network 192.168.255.4 0.0.0.3

no auto-summary

!

ip default-network 192.168.1.0

MLS3 partial configuration:

vlan 10

name test-net10

!

!

!

!

!

!

interface FastEthernet0/1

description To R2

no switchport

ip address 10.1.10.2 255.255.255.0

speed 100

duplex full

!

interface FastEthernet0/3

description To R3

no switchport

ip address 10.1.20.2 255.255.255.0

speed 100

duplex full

!

interface Vlan10

ip address 10.10.10.1 255.255.255.0

!

!

router eigrp 90

network 10.1.10.0 0.0.0.255

network 10.1.20.0 0.0.0.255

network 10.10.10.0 0.0.0.255

!

ip classless

ip default-network 192.168.1.0

Important: ip default-network only supports classful networks.

Advertisements
This entry was posted in Route and tagged , , , . Bookmark the permalink.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google+ photo

You are commenting using your Google+ account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

w

Connecting to %s