Etherchannel: Adding another cable.

Etherchannel: Adding another cable.

by Cyrus Lok on Saturday, May 29, 2010 at 4:10am

I attempt to expand the bandwidth of the present etherchannel.
I have added another cross over cable to fa0/4 of 2950-1 which connects to fa0/7 of 3550-1

3550-1#sh int status

Port Name Status Vlan Duplex Speed Type
Fa0/1 connected trunk a-full a-100 10/100BaseTX
Fa0/2 notconnect 1 auto auto 10/100BaseTX
Fa0/3 connected trunk a-full a-100 10/100BaseTX
Fa0/4 notconnect 1 auto auto 10/100BaseTX
Fa0/5 connected trunk a-full a-100 10/100BaseTX
Fa0/6 notconnect 1 auto auto 10/100BaseTX
Fa0/7 notconnect 1 auto auto 10/100BaseTX

As shown above fa0/7 says not connected. I felt there must be something over 2950-1. But before moving that switch I need to find out more.

3550-1#sh int fa0/8 switchport
Name: Fa0/8
Switchport: Enabled
Administrative Mode: dynamic desirable
Operational Mode: down
Administrative Trunking Encapsulation: negotiate
Negotiation of Trunking: On
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Administrative Native VLAN tagging: enabled
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk Native VLAN tagging: enabled
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk associations: none
Administrative private-vlan trunk mappings: none
Operational private-vlan: none
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL

Protected: false
Unknown unicast blocked: disabled
Unknown multicast blocked: disabled
Appliance trust: none

fa0/7 of 3550-1 is at its default. I do not like cisco’s default.

3550-1(config-if)#switchport mode trunk
Command rejected: An interface whose trunk encapsulation is “Auto” can not be configured to “trunk” mode.
This means encapsulation sets to auto negotiate cannot be configured as trunk.

3550-1(config-if)#switchport trunk en
3550-1(config-if)#switchport trunk encapsulation dot1q

3550-1(config-if)#switchport mode trunk
3550-1(config-if)#

3550-1(config-if)#switchport nonegotiate
3550-1(config-if)#channel-group 1 mode active
3550-1#sh ether 1 summ
Flags: D – down P – bundled in port-channel
I – stand-alone s – suspended
H – Hot-standby (LACP only)
R – Layer3 S – Layer2
U – in use f – failed to allocate aggregator

M – not in use, minimum links not met
u – unsuitable for bundling
w – waiting to be aggregated
d – default port

Number of channel-groups in use: 1
Number of aggregators: 1

Group Port-channel Protocol Ports
——+————-+———–+———————————————–
1 Po1(SU) LACP Fa0/1(P) Fa0/3(P) Fa0/5(P)
Fa0/7(D)

fa0/7 has been added to the channel group 1, it’s still down at the moment.

2950-1#sh int fa0/4 switch
Name: Fa0/4
Switchport: Enabled
Administrative Mode: static access
Operational Mode: down
Administrative Trunking Encapsulation: dot1q
Negotiation of Trunking: Off
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk private VLANs: none
Operational private-vlan: none
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL
Protected: false
Appliance trust: none

fa0/4 of 2950-1 is not a trunk, it is an access port.
2950-1(config)#int fa0/4
2950-1(config-if)#no spanning
2950-1(config-if)#no spanning-tree portfast
2950-1(config-if)#no spanning
2950-1(config-if)#no spanning-tree bpduguard

2950-1(config-if)#switchport mode trunk
2950-1(config-if)#switchport no
2950-1(config-if)#switchport nonegotiate
2950-1#sh int fa0/4 status err

Port Name Status Reason
Fa0/4 err-disabled bpduguard
2950-1#

bpduguard has shutdown port fa0/4 because a switch was added abruptly on this bpduguard enabled port.

2950-1(config)#int fa0/4
2950-1(config-if)#shut
2950-1(config-if)#no shut
2950-1(config-if)#
01:15:45: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/4, changed state to up
2950-1(config-if)#
2950-1(config-if)#
01:15:47: %LINK-3-UPDOWN: Interface FastEthernet0/4, changed state to up
2950-1(config-if)#
2950-1(config-if)#channel-group 1 mode active
2950-1(config-if)#end
2950-1#
01:16:06: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/4, changed state to down
01:16:06: %SYS-5-CONFIG_I: Configured from console by console
2950-1#

2950-1#sh ether 1 summ
Flags: D – down P – in port-channel
I – stand-alone s – suspended
H – Hot-standby (LACP only)
R – Layer3 S – Layer2
u – unsuitable for bundling
U – in use f – failed to allocate aggregator
d – default port

Number of channel-groups in use: 1
Number of aggregators: 1

Group Port-channel Protocol Ports
——+————-+———–+———————————————–
1 Po1(SU) LACP Fa0/1(Pd) Fa0/2(P) Fa0/3(P)
Fa0/4(I)

fa0/4 is on stand-alone, at this time I saw amber light on fa0/7 of 3550-1 which is bad.

3550-1#sh int fa0/7 status

Port Name Status Vlan Duplex Speed Type
Fa0/7 suspended trunk a-full a-100 10/100BaseTX

fa0/7 of 3550-1 is suspended. There must be a mismatch some where.

3550-1#sh ether 1 port
Ports in the group:
——————-
Port: Fa0/1
————

Port state = Up Mstr Assoc In-Bndl
Channel group = 1 Mode = Active Gcchange = –
Port-channel = Po1 GC = – Pseudo port-channel = Po1
Port index = 0 Load = 0x00 Protocol = LACP

Flags: S – Device is sending Slow LACPDUs F – Device is sending fast LACPDUs.
A – Device is in active mode. P – Device is in passive mode.

Local information:
LACP port Admin Oper Port Port
Port Flags State Priority Key Key Number State
Fa0/1 SA bndl 32768 0x1 0x1 0x2 0x3D

Partner’s information:

LACP port Admin Oper Port Port
Port Flags Priority Dev ID Age key Key Number State
Fa0/1 SA 32768 000d.2944.c200 9s 0x0 0x1 0x1 0x3D

Age of the port in the current state: 0d:01h:20m:26s

Port: Fa0/3
————

Port state = Up Mstr Assoc In-Bndl
Channel group = 1 Mode = Active Gcchange = –
Port-channel = Po1 GC = – Pseudo port-channel = Po1
Port index = 0 Load = 0x00 Protocol = LACP

Flags: S – Device is sending Slow LACPDUs F – Device is sending fast LACPDUs.
A – Device is in active mode. P – Device is in passive mode.

Local information:
LACP port Admin Oper Port Port
Port Flags State Priority Key Key Number State
Fa0/3 SA bndl 32768 0x1 0x1 0x4 0x3D

Partner’s information:

LACP port Admin Oper Port Port
Port Flags Priority Dev ID Age key Key Number State
Fa0/3 SA 32768 000d.2944.c200 21s 0x0 0x1 0x2 0x3D

Age of the port in the current state: 0d:01h:18m:50s

Port: Fa0/5
————

Port state = Up Mstr Assoc In-Bndl
Channel group = 1 Mode = Active Gcchange = –
Port-channel = Po1 GC = – Pseudo port-channel = Po1
Port index = 0 Load = 0x00 Protocol = LACP

Flags: S – Device is sending Slow LACPDUs F – Device is sending fast LACPDUs.
A – Device is in active mode. P – Device is in passive mode.

Local information:
LACP port Admin Oper Port Port
Port Flags State Priority Key Key Number State
Fa0/5 SA bndl 32768 0x1 0x1 0x6 0x3D

Partner’s information:

LACP port Admin Oper Port Port
Port Flags Priority Dev ID Age key Key Number State
Fa0/5 SA 32768 000d.2944.c200 21s 0x0 0x1 0x3 0x3D

Age of the port in the current state: 0d:01h:08m:11s

Port: Fa0/7
————

Port state = Up Cnt-bndl Suspend Not-in-Bndl
Channel group = 1 Mode = Active Gcchange = –
Port-channel = null GC = – Pseudo port-channel = Po1
Port index = 0 Load = 0x00 Protocol = LACP

Flags: S – Device is sending Slow LACPDUs F – Device is sending fast LACPDUs.
A – Device is in active mode. P – Device is in passive mode.

Local information:
LACP port Admin Oper Port Port
Port Flags State Priority Key Key Number State
Fa0/7 SA susp 32768 0x1 0x0 0x8 0x45

Age of the port in the current state: 0d:01h:27m:07s

Probable reason: trunk mode of Fa0/7 is trunk, Fa0/1 is dynamic

Well the reason is not correct, there must be something gone wrong.
Great…. because I set fa0/7 as nonegotiate:
3550-1(config-if)#no switchport nonegotiate
3550-1(config-if)#end
3550-1#
*Mar 1 01:34:10.279: %SYS-5-CONFIG_I: Configured from console by console
*Mar 1 01:34:10.347: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/7, changed state to up

Now it’s working. Lesson learned. If one port is set to nonegotiate all ports must be the same.

3550-1#sh etherchannel 1 summ
Flags: D – down P – bundled in port-channel
I – stand-alone s – suspended
H – Hot-standby (LACP only)
R – Layer3 S – Layer2
U – in use f – failed to allocate aggregator

M – not in use, minimum links not met
u – unsuitable for bundling
w – waiting to be aggregated
d – default port

Number of channel-groups in use: 1
Number of aggregators: 1

Group Port-channel Protocol Ports
——+————-+———–+———————————————–
1 Po1(SU) LACP Fa0/1(P) Fa0/3(P) Fa0/5(P)
Fa0/7(P)

3550-1#sh spanning-tree vlan 1

VLAN0001
Spanning tree enabled protocol ieee
Root ID Priority 4097
Address 000b.be08.f480
This bridge is the root
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 4097 (priority 4096 sys-id-ext 1)
Address 000b.be08.f480
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 300

Interface Role Sts Cost Prio.Nbr Type
——————- —- — ——— ——– ——————————–
Po1 Desg FWD 8 128.65 P2p

All working.

Advertisements
This entry was posted in Route. Bookmark the permalink.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google+ photo

You are commenting using your Google+ account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s