Configuring Etherchannel: Add redundancy from 2950-1 to 3550-2

Configuring Etherchannel: Add redundancy from 2950-1 to 3550-2

by Cyrus Lok on Sunday, May 30, 2010 at 10:48pm

2950-1 and 3550-1 has a dot1q etherchannel trunk set up. But this is one single point of failure hence 2950-1 will add another trunk to 3550-2

2950-1 fa0/4 – 6 have no lights:
2950-1#sh int fa0/4 status err

Port Name Status Reason
Fa0/4 err-disabled bpduguard

The command show interface status show that fa0/4 – 6 were in err-disabled state.

2950-1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
2950-1(config)#int fa0/4
2950-1(config-if)#spanning-tree bpduguard disable
2950-1(config-if)#no spanning portfast
2950-1(config-if)#shut
2950-1(config-if)#no shut
2950-1(config-if)#exit

2950-1(config)#int range fa0/5 – 6
2950-1(config-if-range)#spanning-tree bpduguard disable
2950-1(config-if-range)#no spanning portfast
2950-1(config-if-range)#shut
2950-1(config-if-range)#no shut
2950-1(config-if-range)#

From 3550-2, just to make sure.

3550-2#sh int status err
No news is good news.
Layer 3 etherchannel will be configured here.

3550-2(config)#int range fa0/7 , fa0/9 , fa0/11
3550-2(config-if-range)#channel-group 2 mode on
Creating a port-channel interface Port-channel 2

No auto-negotiation will be used, etherchannel will be set up manually.

3550-2(config-if-range)#switchport trunk encapsulation dot1q
3550-2(config-if-range)#switchport mode trunk
3550-2(config-if-range)#switchport nonegotiate
3550-2(config-if-range)#
*Mar 1 00:14:56.043: %EC-5-CANNOT_BUNDLE2: Fa0/7 is not compatible with Fa0/9 and will be suspended (trunk mode of Fa0/7 is trunk, Fa0/9 is dynamic)
*Mar 1 00:14:56.055: %EC-5-CANNOT_BUNDLE2: Fa0/9 is not compatible with Fa0/11 and will be suspended (trunk mode of Fa0/9 is trunk, Fa0/11 is dynamic)
*Mar 1 00:14:56.079: %EC-5-COMPATIBLE: Fa0/7 is compatible with port-channel members
*Mar 1 00:14:56.107: %EC-5-COMPATIBLE: Fa0/9 is compatible with port-channel members
*Mar 1 00:14:56.119: %EC-5-CAN
3550-2(config-if-range)#NOT_BUNDLE2: Fa0/11 is not compatible with Fa0/7 and will be suspended (dtp nonegotiate of Fa0/11 is 0, Fa0/7 id 1)
*Mar 1 00:14:57.059: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/11, changed state to down
3550-2(config-if-range)#
*Mar 1 00:15:02.803: %EC-5-COMPATIBLE: Fa0/11 is compatible with port-channel members
3550-2(config-if-range)#
*Mar 1 00:15:03.811: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/11, changed state to up

That’s crazy so many syslogs. Switch ports take time to adjust on manual configuration.

3550-2#sh etherchannel summ
Flags: D – down P – bundled in port-channel
I – stand-alone s – suspended
H – Hot-standby (LACP only)
R – Layer3 S – Layer2
U – in use f – failed to allocate aggregator

M – not in use, minimum links not met
u – unsuitable for bundling
w – waiting to be aggregated
d – default port

Number of channel-groups in use: 1
Number of aggregators: 1

Group Port-channel Protocol Ports
——+————-+———–+———————————————–
2 Po2(SD) – Fa0/7(D) Fa0/9(D) Fa0/11(D)

This is fine because the other end has not configured etherchannel yet. Suspended is more serious as it means there’s mismatches.

3550-2#conf t
Enter configuration commands, one per line. End with CNTL/Z.
3550-2(config)#int po1
3550-2(config-if)#no switchport
3550-2(config-if)#ip address 10
*Mar 1 00:18:22.211: %LINK-3-UPDOWN: Interface Port-channel1, changed state to down
*Mar 1 00:18:23.211: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel1, changed state to down
3550-2(config-if)#ip address 10.2.1.1 255.255.255.0
3550-2(config-if)#exit

Darn! I accidentally created on po1 which is useless…It should be po2

3550-2(config)#int range fa0/7 , fa0/9 , fa0/11
3550-2(config-if-range)#no switchport
3550-2(config-if)#no switchport
3550-2(config-if)#ip address 10.2.1.1 255.255.255.0

2950-1(config)#int range fa0/4 – 6
2950-1(config-if-range)#switchport mode trunk
2950-1(config-if-range)#switchport nonegotiate
2950-1(config-if-range)#channel-group 2 mode on
Creating a port-channel interface Port-channel 2

2950-1 cannot set to auto-negotiate, it will not work.

2950-1#sh etherchannel summ
Flags: D – down P – in port-channel
I – stand-alone s – suspended
H – Hot-standby (LACP only)
R – Layer3 S – Layer2
u – unsuitable for bundling
U – in use f – failed to allocate aggregator
d – default port

Number of channel-groups in use: 2
Number of aggregators: 2

Group Port-channel Protocol Ports
——+————-+———–+———————————————–
1 Po1(SU) LACP Fa0/1(Pd) Fa0/2(P) Fa0/3(P)
2 Po2(SU) – Fa0/4(Pd) Fa0/5(P) Fa0/6(P)

Po2 is up. Great.

2950-1#ping 10.1.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 1/4/8 ms
2950-1#ping 10.2.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.2.1.1, timeout is 2 seconds:
…..
Success rate is 0 percent (0/5)

Hmmm there’s no problem to 10.1.1.1 but icmp dropped totally to 3550-2

3550-2#sh ip int brief
Interface IP-Address OK? Method Status Protocol
Port-channel2 10.2.1.1 YES manual down down

Oh! It’s down!

3550-2#sh ether summ
Flags: D – down P – bundled in port-channel
I – stand-alone s – suspended
H – Hot-standby (LACP only)
R – Layer3 S – Layer2
U – in use f – failed to allocate aggregator

M – not in use, minimum links not met
u – unsuitable for bundling
w – waiting to be aggregated
d – default port

Number of channel-groups in use: 2
Number of aggregators: 2

Group Port-channel Protocol Ports
——+————-+———–+———————————————–
1 Po1(RD) –
2 Po2(RD) –

No members in channel 2?!

3550-2(config-if-range)#channel-group 2 mode on
*Mar 1 00:37:03.999: %LINK-3-UPDOWN: Interface Port-channel2, changed state to up
*Mar 1 00:37:04.999: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel2, changed state to up

Alright it’s up.

3550-2#sh ip int brief
Port-channel2 10.2.1.1 YES manual up up

3550-2#sh ether summ
Flags: D – down P – bundled in port-channel
I – stand-alone s – suspended
H – Hot-standby (LACP only)
R – Layer3 S – Layer2
U – in use f – failed to allocate aggregator

M – not in use, minimum links not met
u – unsuitable for bundling
w – waiting to be aggregated
d – default port

Number of channel-groups in use: 2
Number of aggregators: 2

Group Port-channel Protocol Ports
——+————-+———–+———————————————–
1 Po1(RD) –
2 Po2(RU) – Fa0/7(P) Fa0/9(P) Fa0/11(P)

Port channel that’s up should look like this!

3550-2#copy run start
Destination filename [startup-config]?
Building configuration…
[OK]
3550-2#

2950-1#ping 10.2.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.2.1.1, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 1/3/4 ms

Redundant link is up!

Advertisements
This entry was posted in Route. Bookmark the permalink.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google+ photo

You are commenting using your Google+ account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s