Configuring Etherchannel: 2950-2 and 3550-2

Configuring Etherchannel: 2950-2 and 3550-2

by Cyrus Lok on Sunday, May 30, 2010 at 11:29pm
Let’s see which ports of 2950-2 are blocked…

2950-2#sh spanning vlan 1

VLAN0001
Spanning tree enabled protocol ieee
Root ID Priority 8193
Address 000c.85e5.5380
Cost 19
Port 1 (FastEthernet0/1)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 32769 (priority 32768 sys-id-ext 1)
Address 0016.9d05.5080
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 15

Interface Role Sts Cost Prio.Nbr Type
—————- —- — ——— ——– ——————————–
Fa0/1 Root LRN 19 128.1 P2p
Fa0/2 Altn BLK 19 128.2 P2p
Fa0/3 Altn BLK 19 128.3 P2p

2950-2#sh run int fa0/1
Building configuration…

Current configuration : 80 bytes
!
interface FastEthernet0/1
switchport mode trunk
switchport nonegotiate
end

2950-2#sh run int fa0/2
Building configuration…

Current configuration : 80 bytes
!
interface FastEthernet0/2
switchport mode trunk
spanning-tree portfast
end

2950-2#sh run int fa0/3
Building configuration…

Current configuration : 81 bytes
!
interface FastEthernet0/3
switchport mode access
spanning-tree portfast
end

What?! fa0/2 and fa0/3 are trunk but in portfast?! That’s crazy! Don’t do this! This will cause a temporary loop!

2950-2(config)#int range fa0/1 – 3
2950-2(config-if-range)#description Connects to 3550-2
2950-2(config-if-range)#no spanning-tree portfast
2950-2(config-if-range)#switchport mode trunk
2950-2(config-if-range)#
00:04:06: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/3, changed state to down
2950-2(config-if-range)#
00:04:09: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/3, changed state to up
2950-2(config-if-range)#switchport nonegotiate

2950-2(config-if-range)#channel-group 1 mode on
Creating a port-channel interface Port-channel 1

2950-2(config-if-range)#
00:05:43: %EC-5-CANNOT_BUNDLE2: Fa0/2 is not compatible with Fa0/1 and will be suspended (trunk mode of Fa0/2 is dynamic, Fa0/1 is trunk)
00:05:43: %EC-5-CANNOT_BUNDLE2: Fa0/3 is not compatible with Fa0/1 and will be suspended (trunk mode of Fa0/3 is dynamic, Fa0/1 is trunk)
00:05:44: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed state to down
2950-2(config-if-range)#
00:05:44: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/3, changed state to down
2950-2(config-if-range)#
00:05:45: %LINK-3-UPDOWN: Interface Port-channel1, changed state to up
00:05:46: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel1, changed state to up
2950-2(config-if-range)#do sh ether summ
Flags: D – down P – in port-channel
I – stand-alone s – suspended
H – Hot-standby (LACP only)
R – Layer3 S – Layer2
u – unsuitable for bundling
U – in use f – failed to allocate aggregator
d – default port

Number of channel-groups in use: 1
Number of aggregators: 1

Group Port-channel Protocol Ports
——+————-+———–+———————————————–
1 Po1(SU) – Fa0/1(Pd) Fa0/2(s) Fa0/3(s)

Why can’t fa0/2 and fa0/3 be bundled? All ports are in no negotiate and in trunk.

2950-2(config-if-range)#do sh run int fa0/2
Building configuration…

Current configuration : 137 bytes
!
interface FastEthernet0/2
description Connects to 3550-2
switchport mode trunk
switchport nonegotiate
channel-group 1 mode on
end

2950-2(config-if-range)#
2950-2(config-if-range)#do sh run int fa0/3
Building configuration…

Current configuration : 137 bytes
!
interface FastEthernet0/3
description Connects to 3550-2
switchport mode trunk
switchport nonegotiate
channel-group 1 mode on
end

2950-2(config-if-range)#

2950-2#sh vlan brief

VLAN Name Status Ports
—- ——————————– ——— ——————————-
1 default active Fa0/2, Fa0/3, Fa0/4, Fa0/5
Fa0/6, Fa0/7, Fa0/8, Fa0/9
Fa0/10, Fa0/11, Fa0/12, Fa0/13
Fa0/14, Fa0/15, Fa0/16, Fa0/17
Fa0/18, Fa0/19, Fa0/20, Fa0/21
Fa0/22, Fa0/23, Fa0/24
1002 fddi-default act/unsup
1003 trcrf-default act/unsup
1004 fddinet-default act/unsup
1005 trbrf-default act/unsup
2950-2#

fa0/3 and fa0/5 are in vlan 1?! They should not be there! Which means they are in access mode instead of trunking mode.

3550-2#sh int status

Port Name Status Vlan Duplex Speed Type
Fa0/1 connected trunk a-full a-100 10/100BaseTX
Fa0/2 notconnect 1 auto auto 10/100BaseTX
Fa0/3 connected 1 a-full a-100 10/100BaseTX
Fa0/4 notconnect 1 auto auto 10/100BaseTX
Fa0/5 connected 1 a-full a-100 10/100BaseTX
Fa0/6 notconnect 1 auto auto 10/100BaseTX

only fa0/1 is trunk, fa0/3 and fa0/5 are in access mode…why?

3550-2#sh run int fa0/3
Building configuration…

Current configuration : 68 bytes
!
interface FastEthernet0/3
switchport mode dynamic desirable
end

3550-2#
3550-2#sh run int fa0/5
Building configuration…

Current configuration : 68 bytes
!
interface FastEthernet0/5
switchport mode dynamic desirable
end

This is strange….they are in dynamic desirable, so they should be a trunk automatically.

3550-2#sh int fa0/3 switchport
Name: Fa0/3
Switchport: Enabled
Administrative Mode: dynamic desirable
Operational Mode: static access
Administrative Trunking Encapsulation: negotiate
Operational Trunking Encapsulation: native
Negotiation of Trunking: On
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Administrative Native VLAN tagging: enabled
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk Native VLAN tagging: enabled
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk associations: none
Administrative private-vlan trunk mappings: none
Operational private-vlan: none
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL

Protected: false
Unknown unicast blocked: disabled
Unknown multicast blocked: disabled
Appliance trust: none

Huh? In static access operational mode?

3550-2(config)#int range fa0/1 , fa0/3 , fa0/5
3550-2(config-if-range)#description Connects to 2950-2
3550-2(config-if-range)#switchport trunk encapsulation dot1q
3550-2(config-if-range)#switchport mode trunk
3550-2(config-if-range)#switchport nonegotiate
3550-2(config-if-range)#do sh int trunk

Port Mode Encapsulation Status Native vlan
Fa0/1 on 802.1q trunking 1
Fa0/3 on 802.1q trunking 1
Fa0/5 on 802.1q trunking 1

Port Vlans allowed on trunk
Fa0/1 1-4094
Fa0/3 1-4094
Fa0/5 1-4094

Port Vlans allowed and active in management domain
Fa0/1 1
Fa0/3 1
Fa0/5 1

Port Vlans in spanning tree forwarding state and not pruned
Fa0/1 1
Fa0/3 1
Fa0/5 1
3550-2(config-if-range)#

Lesson learned: Don’t use the automatic feature!

3550-2(config)#int po1
3550-2(config-if)#no shut
3550-2(config-if)#
*Mar 1 01:07:22.863: %LINK-3-UPDOWN: Interface Port-channel1, changed state to down
3550-2(config-if)#ip address 10.3.1.1 255.255.255.0

3550-2(config-if)#int range fa0/1 , fa0/3 , fa0/5
3550-2(config-if-range)#no switchport

3550-2(config-if-range)#channel-group 1 mode on
3550-2(config-if-range)#
*Mar 1 01:08:38.979: %LINK-3-UPDOWN: Interface Port-channel1, changed state to up
*Mar 1 01:08:39.979: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel1, changed state to up

3550-2(config-if-range)#do sh ether summ
Flags: D – down P – bundled in port-channel
I – stand-alone s – suspended
H – Hot-standby (LACP only)
R – Layer3 S – Layer2
U – in use f – failed to allocate aggregator

M – not in use, minimum links not met
u – unsuitable for bundling
w – waiting to be aggregated
d – default port

Number of channel-groups in use: 2
Number of aggregators: 2

Group Port-channel Protocol Ports
——+————-+———–+———————————————–
1 Po1(RU) – Fa0/1(P) Fa0/3(P) Fa0/5(P)
2 Po2(RU) – Fa0/7(P) Fa0/9(P) Fa0/11(P)

Po1 is up.

2950-2#sh int fa0/2 status

Port Name Status Vlan Duplex Speed Type
Fa0/2 Connects to 3550-2 notconnect trunk a-full a-100 10/100BaseTX
2950-2#sh etherchannel summ
Flags: D – down P – in port-channel
I – stand-alone s – suspended
H – Hot-standby (LACP only)
R – Layer3 S – Layer2
u – unsuitable for bundling
U – in use f – failed to allocate aggregator
d – default port

Number of channel-groups in use: 1
Number of aggregators: 1

Group Port-channel Protocol Ports
——+————-+———–+———————————————–
1 Po1(SU) – Fa0/1(Pd) Fa0/2(s) Fa0/3(s)

fa0/2 and fa0/3 are suspended.. again.. mismatches some where.

2950-2#sh ip int brief
Interface IP-Address OK? Method Status Protocol
Vlan1 10.10.10.3 YES NVRAM up up
FastEthernet0/1 unassigned YES unset up up
FastEthernet0/2 unassigned YES unset up down
FastEthernet0/3 unassigned YES unset up down

2950-2#sh run int fa0/2
Building configuration…

Current configuration : 137 bytes
!
interface FastEthernet0/2
description Connects to 3550-2
switchport mode trunk
switchport nonegotiate
channel-group 1 mode on
end

protocol down… layer2 mismatch… wth…

2950-2(config)#int range fa0/2 – 3
2950-2(config-if-range)#switchport mode trunk
2950-2(config-if-range)#switchp
00:27:11: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed state to up
00:27:11: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/3, changed state to up
2950-2(config-if-range)#switchport nonnegotiate

So I did not set the ports to trunk? cannot be…

2950-2#sh etherchannel summ
Flags: D – down P – in port-channel
I – stand-alone s – suspended
H – Hot-standby (LACP only)
R – Layer3 S – Layer2
u – unsuitable for bundling
U – in use f – failed to allocate aggregator
d – default port

Number of channel-groups in use: 1
Number of aggregators: 1

Group Port-channel Protocol Ports
——+————-+———–+———————————————–
1 Po1(SU) – Fa0/1(Pd) Fa0/2(P) Fa0/3(P)

Ok now it’s working.

2950-2#ping 10.3.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.3.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/3/4 ms

All good to go.

Advertisements
This entry was posted in Route. Bookmark the permalink.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s